link icon
Ask The Community

Cannot connect to Teamviewer server since yesterday

I am using an android mobile TV client to connect to my home PC so I can access while I am out. Everything worked fine until yesterday. Now when trying to connect I get prompted for a password. After I enter the password it just sits there saying "please wait while connecting" and shows the spinning symbol. If I look at the server at the very same time I can see that the client appears in the connection list. I also have it set so I can connect via wifi using the android mobile locally using the internal IP of the server which also worked fine first thing yesterday but now has the same problem as trying to connect externally. I think I noticed a TV update to the mobile client which might have been yesterday but I can be 100% sure. I've rebooted phone, server, wifi router all to no avail. Anyone any idea what to try next? I have also been getting messages "commercial use suspected" but I ignored them as I am not using comercially just for family and personal network and have no server OS all win 7.

Best Answer


  • Just to clarify, when I say server I just mean the Win 7 PC I am trying to connect to from the Android client. It is not running a server o/s, should have called it the Host rather than server sorry.

  • Can anyone from TV help? I know Im not a paying customer so probably not very high on your list of priorities but if you offer a free option for non commercial use it would be useful to be able to get things working when they break :)

  • Thank you for your reply and assurance that both paid and free users are all equal here :)

    I've had a look at the thread and yes this is the exact same issue so thanks for confirmation its being worked on.

    Look forward to an android client update to fix things

    Thanks again.

Sign In or Register to comment.