teamviewer.com link icon
or
Ask The Community

Host Notebook with closed lid

Ok, my notebook is set "to do nothing" with the lid closed.

So when I connect I get a black screen, has anyone found any solution to this issue. It's not a likely situation that this would happen to me in real time since if I'm remote I using the notebook. But since I'm at my home location and I have the notebook doing a Cloud backup full I just happened to  log onto it and all I get is a black screen

I have 2 desktops on window 10   1803 Pro 1 HP All in one  on 8.1 Pro and my notebook Asus G752VW on 10 pro 1803

I'm a fairly switched on user participating in a couple of different support  forums 

I am also moving over from "Go To My PC" they have priced themselves out of the market for home users like my self that only connect to one other computer at a time, I do my personal finances etc remotely from my SubSea Consulting job.

I haven't found anywhere to set up a profile or signature etc on this forum so far, I'll update it if that is possible?

 

Clinton J Wright

Best Answers

Answers

  • I'm getting the same thing. It suddenly started happening after a windows update this past week (~May 14, 2018). It was working fine before that - but now, whenever the lid is closed on the remote laptop all I get a black screen. When the lid is open, it works fine. The laptop is all the way across the country, so I have to call a friend to open it whenever I want to log in - very frustrating.

  • Scotty
    Scotty Posts: 494 Staff

    Hi Everyone,

    This is not a bug or error unfortunately.
    TeamViewer can only display the screen from the remote side if there is a display to show.

    Unfortunately, many devices when their screens are off or not connected will simply not generate a display meaning that TeamViewer can only show a blank screen. It is likely that during the update, this has changed as a power saving method.

    Long story short, the remote side must be generating a display for you to be able to remote in because we are just mimicking what is available on the remote side.

    To fix this, you would need a way to make the remote side generate a display with the lid closed. Even an external monitor or dummy plug would work.

    This is also true with "Headless" systems.

    Sorry for the hassle,
    -Scotty

    Senior Moderator
    Did my reply answer your question? Why not accept it as a solution to help others?
  • Scotty
    Scotty Posts: 494 Staff
    Hi MediaBizDev,

    I do understand the issue and frustration. My laptop actually did the opposite in the latest update and I can now do it when I could not before.

    It's all to do with the drivers and nothing to do with the settings in windows. If it was, I would give you the settings to fix it.

    Even though you have set it so the screen "does not turn off" I gaurantee it does when you close the lid. Your screen is now essentially headless as the screen is no longer connected and your GPU is no longer generating a display for TeamViewer to capture.

    Of course you can click things, you are remoted in. But the GPU is still not generating a display for us to capture.

    Take a screeshot while connected with TV. It will be black because there is no display.

    I am sorry, but the only way to fix it is to force the device to generate a display output.

    -Scotty
    Senior Moderator
    Did my reply answer your question? Why not accept it as a solution to help others?
  • Manukeno
    Manukeno Posts: 1

    I had the same issue and got it fixed by installing the Teamviewer Display Driver. It can be found here: teamviewer->tools->options->advanced->advanced network settings->install display driver.

    Maybe this helps you too.

  • Scotty
    Scotty Posts: 494 Staff

    Hi Manukeno,

    I am glad you found a solution!
    Just note this is not what this driver is intended for.

    Changing the driver to any other universal display driver may fix the issue, but you may also not be able to adjust brightness on the laptop.

    -Scotty

    Senior Moderator
    Did my reply answer your question? Why not accept it as a solution to help others?
  • Thank you! This method worked for me.
  • Just upgraded from Win 7 (where it was working fine with the lid closed) to  Win 10 - where it instantly loses visual updates and appears to freeze - though mouse clicks continuue. My  closed lid laptop used as a server,,, is now worthless.

    I can't understand the explanation here. Or rather, I can, but I can't understand what is the inherent difference between OS that means TeamViewer looses video connection (not actual connection) when the lid is closed.

    A lot of people are coming off 7 as it's going out of support. Is there any releif at all in Windows 10 settings or hacks? Seems like something TeamViewwer should have a workaround for.

  • Clintlgm
    Clintlgm Posts: 4 ✭✭

    Yes, go to control panel/power options/advanced options/ find Power button, there you'll find a selection for what closing your lid does. select Do Nothing

    Clinton J Wright
  • I have always used this setting. It worked for Win 7 but in Win 10, even though it's still set, the video instantly stops capturing as soon as the lid is closed.

  • The following worked for me. I am running Windows 10 v1909....

    With the lid closed, do the following (even though you don;t see anything - Windows is still running, but it is not sending anything to a closed display):

    1.  Windows Key + letter 'P' (will open the setting for multiple displays *)

    2.  Press Enter 

    If the above doesn't work, press Windows key + 'P' more than once to toggle between different options:

    -  PC screen only
    -  Duplicate
    -  Extend
    -  Second screen only

    * IMPORTANT Make sure you have enabled the TeamViewer option Send key combinations for the remote computer

  • Thanks a lot. It does the trick! 


    @babble2fish wrote:

    The following worked for me. I am running Windows 10 v1909....

    With the lid closed, do the following (even though you don;t see anything - Windows is still running, but it is not sending anything to a closed display):

    1.  Windows Key + letter 'P' (will open the setting for multiple displays *)

    2.  Press Enter 

    If the above doesn't work, press Windows key + 'P' more than once to toggle between different options:

    -  PC screen only
    -  Duplicate
    -  Extend
    -  Second screen only

    * IMPORTANT Make sure you have enabled the TeamViewer option Send key combinations for the remote computer


     

  • UltraDark
    UltraDark Posts: 1

    Worked for me!

    All seemed pretty hopeless then this simple fix appeared.

    Thanks.


  • @babble2fish wrote:

    The following worked for me. I am running Windows 10 v1909....

    With the lid closed, do the following (even though you don;t see anything - Windows is still running, but it is not sending anything to a closed display):

    1.  Windows Key + letter 'P' (will open the setting for multiple displays *)

    2.  Press Enter 

    If the above doesn't work, press Windows key + 'P' more than once to toggle between different options:

    -  PC screen only
    -  Duplicate
    -  Extend
    -  Second screen only

    * IMPORTANT Make sure you have enabled the TeamViewer option Send key combinations for the remote computer


    I have an HP Laptop from 2010 that came with Win7 and was recently upgraded to Win10.  Like others, this stopped working when I did the upgrade, however, playing with the projection settings worked for me as well.  Good call.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!