link icon
Ask The Community

TeamViewer is one of the winners of the European Customer Centricity Award 🥳

Please find more information here.

Teamviewer 15 error - "Unable to Connect. Reason unknown. The remote TeamViewer is out of date" but

Running TeamViewer full version, 15.0.8397, I create a session code. The client uses the code at, downloads TeamViewer QS and gets the green "ready to connect" message. I get the message "Service case is online". So far so good. But when I then try to prompt for remote control of the client machine I get 2 error message boxes. The first says "The remote TeamViewer is running an old version which is out of date. Therefore you cannot connect to this version anymore. Your connection partner can update TeamViewer by clicking on Help - Check for new version." Then next box says "Unable to connect. Reason unknown".

Very strange considering both the client with TeamViewer QS and the Full version which is trying to connect are runing the latest versions of Team Viewer.

I was interested in using team viewer commercially, but I can't even get off the launchpad.



  • ÆGIS
    ÆGIS Posts: 2

    Same for us. TeamViewer is not willing to help.
    This error was discussed so many time without any official statement.

    We try to connect from 15 to 14 ... does not work.
    And supporthotline does not know what they are talking about.
    They keep telling us its backwardscompatible but wont get that it is NOT 
    for it does not work

    I have the feeling this error is caused intentionaly by teamviewer to sell newer licenses


  • Yes, only I'm not trying to connect between different versions. Both hosts are on the same version, version 15.0.8397. So the error message makes no sense. It's saying the remote side is running an older verion, but that's false. Both side are running the latest version available. Also, I don't have a license. I'm using Teamviewer free for personal use. If I can get it to work for me personally, then yeah, maybe I will buy a comercial licnece. I would like it to actually work for me before buying a licence. Saves me trouble on the phone and with my credit card to get a refund in the event that it continues not to work for me even after I've paid. Meanwhile I've been looking into other solutions, like Google Remote Desktop for the Chrome browser which is really the way to go for supporting Chrome Books. On the Mac side, Apple's Messages application allows for screensharing with the person you're chatting with.

  • i tried/test the remote session before i left town, worked fine.  now i'm out of town, and trying to connect and it says unable to connect, remote is on a old version?  Help?

  • 5 months and for minor version numbers later the issue appears to have been resolved in version  15.4.4445. I no longer get the "remote TeamViewer is out of date message."

    I'm running TeamViewer full version on Mac OS Mojave and was able to connect to a Mac running High Sierra and another Mac running El Capitan. So TeamViewer is once again working as advertised.