link icon
Ask The Community

TeamViewer 14 on Pi (Raspbian 9) not connecting following restart.

Hi All, I'm new to the forum, and not an experienced Lunix user, so please bear with me.
I am currently using TeamViewer 14 on Raspberry Pi. The Pi is running Raspbian 9 (Stretch).

I installed TV Linux Host (latest version from TV website) and connected it to my account. Continued with configuring the device, then reboot - no connection. The message displayed is Not ready. Please check your connection.

If I run the command sudo teamviewer daemon restart, then it works fine. But this isn't really helpful as I would have to go to the device every time to get it working.

I have logged a support ticket with TeamViewer, but thought I would post here to see if anyone else has had a similar issue.

If you are replying in a tech manner regarding Linux, please do it in such a way a 5 yr old would undertsand. I am a Windows admin with little / no Linux experience, I have to google everything I do :-)



  • I am experiencing the exact same thing on a new raspberry pi install with teamviewer 14.

    I noticed in the logs that the server name couldn't be resolved at service startup.  I wonder if teamviewer is trying to start before the network is running.

  • This sounds like a plausable theory.

    My workaround currently is to use v.13. Luckily I already have some Pi's deployed and the install file was still in the download folder. This I now have nice and safe in my gmail account!

    I have also raised a support ticket, so if I get a resolution I can post it up.

  • Dom
    Dom Posts: 13

    This has been a problem since the half baked TeamViewer 13 and it has been passed on in TeamViewer 14. In TeamViewer 12 and all version I have used below we were able to issue a simple reboot. TeamViewer would run on the guest machine at system startup and we would be able to log into the guest machine. Not anymore and what I do not understand is why as this is a key feature of TeamViewer and we need it back. TeamViewer should never have released TeamViewer 13 in the "Preview" nonsense it was and a native linux version should have been built in the background rather than giving us a broken and incomplete product.

    I am absolutely dissapointed this has not been fixed in TeamViewer 14 and that means that it looks like for another year I will be forced to use and deploy TeamViewer 12 because the developers are not focused on giving all the features we use to have to the native linux version.

    It is reaching the point I might need to look at other Remote Support Providers who care about their clients and develop fully working products.

  • Login as root, double check your IP settings (for test use static IP and DNS) and run following commands in shell:

    sudo teamviewer daemon stop
    rm -f /opt/teamviewer/config/global.conf
    sudo teamviewer daemon start

    Then relaunch and reconfigure TeamViewer. After that, TeamViewer should work properly.

  • Update: After reverting to TeamViewer 13 and all working well, I have got my test PI, removed TV Host v13, and installed the lates version via the TV website, v14.0.14470 H.

    It now works perfectly, which is quite frustrating! I guess my next step would be to reset the Pi, and try again, but as v13 works ok for me, I am happy to stick with that for now.

  • IgorZ
    IgorZ Posts: 5


    This is dont work.!!!

    only teamviewer host v13 works stably!!!

    @JaroslavSuty wrote:

    Login as root, double check your IP settings (for test use static IP and DNS) and run following commands in shell:

    sudo teamviewer daemon stop
    rm -f /opt/teamviewer/config/global.conf
    sudo teamviewer daemon start

    Then relaunch and reconfigure TeamViewer. After that, TeamViewer should work properly.


  • EnTiTy
    EnTiTy Posts: 1

    I'm also running into this issue; strangely enough, if I plug in a video cable to a monitor and restart, teamviewer works fine, but if I unplug all video outputs, then teamviewer doesn't work after a restart.  

  • I'm having the same issue. I notice that when I go through the setup again via command line (

    sudo teamviewer setup

    ), I am able to connect. I've tried everything I can think of short of wiping the OS:

    - Checking logs

    - Restarting the TV daemon

    - Disabling, restarting, then re-enabling the TV daemon

    - Setting a password

    - Combinations of the above mentioned with and without sudo

    While I could write a bash script to automatically enter in the credentials during startup, that really isn't a good solution to this problem. When I restart my raspberry pi, the teamviewer daemon is running, I get a notification on my Windows PC that the raspberry pi has signed in, and yet I can't connect without going through the setup process on the pi (via something like SSH). This is all happening on a headless raspberry pi without a monitor. 

  • Found this on another site and thought I would post here in the hopes it helps....

    Your pi's GUI isn't starting on headless reboot because you don't have a default resolution set in raspi-config.  Go to terminal edit raspi-config:

    sudo raspi-config

    Under "Advanced" settings you can set a default screen resolution and frequency so that your GUI will start without a monitor (by default it pulls these from the monitor).  Teamviewer 14 worked for me without issue after doing this on Rasberrypi 4.  Hope this helps someone else with my issue!!

  • Thanks @mattnorman fixing the resolution worked for me.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!