teamviewer.com link icon
or
Ask The Community

How to send special keystrokes

When I'm controlling a remote windows machine, how do I send a keystroke like "alt+tab"? Is there a virtual keyboard that I'm missing?

Best Answer

Answers

  • Oh; I see it now while using the desktop app. I was using the Chrome browser app, and it's (understandably) more limited than the desktop app. Thank you!
  • SWAG_B
    SWAG_B Posts: 1

    Chrome OS version doesnt seem to have this option, or am i missing something?

  • Using Teamviewer for mac 13.1.4170

    Can't find this option ANYWHERE.

    HELP!

    (Thanks!)

    -A

     

     

     

     

     

  • hugolia
    hugolia Posts: 1

    I had no “Send key combinations” option...

    How do I enable this option?

     

     

  • gariki
    gariki Posts: 7

    Hi, 

    I dont see this option on the windows app. Is this hiding somewhere?

  • hkppl
    hkppl Posts: 1

    OPTION => REMOTE CONTROL => SEND KEY COMBINATION

  • gariki
    gariki Posts: 7

    I was using a windows app which did not have this option. After i installed the desktop application its working well now. thank you!

     

  • b5969e5e
    b5969e5e Posts: 1

    I am using the TeamViewer 14 Linux client to access a Windows 10 host. I cannot find this option in any of the places mentioned above. Is it supported in my setup at all?

  • brunob
    brunob Posts: 1

    Doesn't work for me. The option is selected, still CMD-ALT-ESC doesn't work on my remote

    (OSX Mavericks to MacOS Sierra)

     

  • mardus
    mardus Posts: 7

    Well, it's not sending ANY combination shortcuts to after effects (from osx 10.13.6 to win10).

  • naveen2112
    naveen2112 Posts: 1

    Even still, I cannot send certain key combinations. For Instance "Win + D" and  "Ctrl+Alt+Shift+Q"  doesn't seem to work. Should I enable anything else? FYI: I am connecting to a Ubuntu Machine from a Windows Machine.

  • I am using Teamviewer 14 aswell on both host and client but this option does not seem to be supported on linux.

    Did anyone find a solution to this?

  • So clearly to this date, this option is still missing from teamviewer desktop app for linux. Is development team thinking of implementing it at all?

  • LarsV
    LarsV Posts: 3

    Hi,

    i'm using V15 and have this option activated, but the key ALT-1 is not sendet to the remote Desktop.

    i need this for the applikation Dexpot - this is a multidesktoptool.

    kindly regards,
    Lars

  • gardan
    gardan Posts: 5

    Hi I did this and ticked the send key combinations , but my f9 key still wont work on the remote PC, has anyone else experienced this and perhaps got a further solution?

    many thanks

  • gardan
    gardan Posts: 5

    I wonder if this does not work because I am using the Free version of teamviewer ?

  • LarsV
    LarsV Posts: 3

    In my case i use the commercial version

  • gardan
    gardan Posts: 5

    so it may be because I'm usig the free version?  I would be interested to know.

  • iKJH
    iKJH Posts: 1

    SOLUTION

    If you cannot find the Actions tab as described in the recommended answer, it is because there is no Actions tab on the client application itself. You have to open a VM and then look for the UI.

    1 Open the virtual machine instance up you want to send keystrokes through.

    2 Look for the interface on top of the actual virtual machine screen. It may be hidden and looks like a small grey rectangle on the top of the screen.

    3 If its not hidden you will see a lightning bolt icon called Actions. Send key combinations is here. Check mark the setting and you are good to go 

  • I had the same problem when I used TV Desktop to start a microsoft RDP session into our server - the shift button didn't even work! Here's why.... Even though I had checked 'Send Key Combinations' it still did not fix the problem. When I Unchecked 'Disable remote input' on the Actions tab - that fixed it! I could send special key combinations! To me, this is a bug and should be fixed (are you listening Teamviewer???) since it is bad security to leave 'Disable remote input' unchecked!

Sign In or Register to comment.