teamviewer.com link icon
or
Ask The Community

Having dependency problems when installing teamviewer deb package 15.2.2756 on linux mint 19.3

I'm trying to install teamviewer 15.2.2756 on a linux munt 19.3 machine. the terminal indicates the following:

dpkg: dependency problems prevent configuration of teamviewer:
teamviewer depends on libqt5qml5 (>= 5.5) | qt56-teamviewer; however:
Package libqt5qml5 is not installed.
Package qt56-teamviewer is not installed.
teamviewer depends on libqt5quick5 (>= 5.5) | qt56-teamviewer; however:
Package libqt5quick5 is not installed.
Package qt56-teamviewer is not installed.
teamviewer depends on libqt5webkit5 (>= 5.5) | qt56-teamviewer; however:
Package libqt5webkit5 is not installed.
Package qt56-teamviewer is not installed.
teamviewer depends on libqt5x11extras5 (>= 5.5) | qt56-teamviewer; however:
Package libqt5x11extras5 is not installed.
Package qt56-teamviewer is not installed.
teamviewer depends on qml-module-qtquick2 (>= 5.5) | qt56-teamviewer; however:
Package qml-module-qtquick2 is not installed.
Package qt56-teamviewer is not installed.
teamviewer depends on qml-module-qtquick-controls (>= 5.5) | qt56-teamviewer; however:
Package qml-module-qtquick-controls is not installed.
Package qt56-teamviewer is not installed.
teamviewer depends on qml-module-qtquick-dialogs (>= 5.5) | qt56-teamviewer; however:
Package qml-module-qtquick-dialogs is not installed.
Package qt56-teamviewer is not installed.
teamviewer depends on qml-module-qtquick-window2 (>= 5.5) | qt56-teamviewer; however:
Package qml-module-qtquick-window2 is not installed.
Package qt56-teamviewer is not installed.
teamviewer depends on qml-module-qtquick-layouts (>= 5.5) | qt56-teamviewer; however:
Package qml-module-qtquick-layouts is not installed.
Package qt56-teamviewer is not installed.

dpkg: error processing package teamviewer (--install):
dependency problems - leaving unconfigured

How do I obtain these dependencies?

Thanks in advance

Tagged:

Best Answer

Answers

  • I am having this exact dependency problem on Ubuntu 18.04.4 LTS (amd64) and would like to know the solution too.

  • I poked around the net a bit more and got a suggestion to install gdebi

    Turns out gdebi wouldn't install due to a broken install (ie. TeamViewer) and suggested:

    sudo apt --fix-broken install

    actually worked and TeamViewer is now running!

    Hope it works for you too!

     

  • I uninstalled TV and reinstalled with gdebi and now only get a teamviewer window with a blank white screen.

  • Sorry if I created any confusion.

    I didn't have to use gdebi

    I should also note that I am on Ubuntu 18.04 (amd64).

    That said, I got the same exact dependency errors you got on install in Mint.

    apt was able to resolve the dependency issues with the "--fix-broken" switch.

    Hoping it might work for you too.

    If not, we may need to wait for someone also on Mint to chime in.

  • I appreciate the help, I'm a noob at Linux. I only have been trying out Linux for a couple weeks.

    I uninstalled TV again and tried the following command in a terminal:

    ~$ sudo --fix-broken apt install ./home/jeff/teamviewer_i386.deb

    and got this response:

    sudo: unrecognized option '--fix-broken'
    usage: sudo -h | -K | -k | -V
    usage: sudo -v [-AknS] [-g group] [-h host] [-p prompt] [-u user]
    usage: sudo -l [-AknS] [-g group] [-h host] [-p prompt] [-U user] [-u user]
    [command]
    usage: sudo [-AbEHknPS] [-r role] [-t type] [-C num] [-g group] [-h host] [-p
    prompt] [-T timeout] [-u user] [VAR=value] [-i|-s] [<command>]
    usage: sudo -e [-AknS] [-r role] [-t type] [-C num] [-g group] [-h host] [-p
    prompt] [-T timeout] [-u user] file ...

    Am I doing this wrong?

    Thanks again, Jeff

  • these instructions look like the same instructions I followed:

    https://www.itzgeek.com/how-tos/linux/linux-mint-how-tos/how-to-install-teamviewer-on-linux-mint-19-linux-mint-18.html 

    ideally this is all you have to do and you're good to go.

    you only need this command if you get the same dependency errors you pasted in your original post:

    sudo apt --fix-broken install

     

  • Uninstalled TV again. Followed the instructions in the link, Ran TV from terminal with the command "teamviewer". Still a blank white Teamviewer screen. This happens for any TV screen I open; options, about, show computers and contacts. Also the terminal prompt freezes after the following:

    [email protected]:~$ teamviewer

    Init...
    CheckCPU: SSE2 support: yes
    Checking setup...
    Launching TeamViewer ...
    Launching TeamViewer GUI ...

    I have to ^C to get back to the prompt

    I think this is another problem

    ScreenshotScreenshot

    BTW, I get the same blank screen if I start TV from the menu.

  • thanks brother, this is work for me

  • neo2020neo2020 Posts: 1

    I still have the issue. Can you advise pls ?

     

    [email protected]:/home/ubuntu/Downloads# apt --fix-broken install
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    0 upgraded, 0 newly installed, 0 to remove and 263 not upgraded.
    [email protected]:/home/ubuntu/Downloads# sudo apt install ./teamviewer_15.7.6_amd64.deb
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Note, selecting 'teamviewer' instead of './teamviewer_15.7.6_amd64.deb'
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    teamviewer : Depends: libqt5gui5 (>= 5.5) but it is not installable or
    qt56-teamviewer but it is not installable
    Depends: libqt5widgets5 (>= 5.5) but it is not installable or
    qt56-teamviewer but it is not installable
    Depends: libqt5qml5 (>= 5.5) but it is not installable or
    qt56-teamviewer but it is not installable
    Depends: libqt5quick5 (>= 5.5) but it is not installable or
    qt56-teamviewer but it is not installable
    Depends: libqt5dbus5 (>= 5.5) but it is not installable or
    qt56-teamviewer but it is not installable
    Depends: libqt5webkit5 (>= 5.5) but it is not installable or
    qt56-teamviewer but it is not installable
    Depends: libqt5x11extras5 (>= 5.5) but it is not installable or
    qt56-teamviewer but it is not installable
    Depends: qml-module-qtquick2 (>= 5.5) but it is not installable or
    qt56-teamviewer but it is not installable
    Depends: qml-module-qtquick-controls (>= 5.5) but it is not installable or
    qt56-teamviewer but it is not installable
    Depends: qml-module-qtquick-dialogs (>= 5.5) but it is not installable or
    qt56-teamviewer but it is not installable
    Depends: qml-module-qtquick-window2 (>= 5.5) but it is not installable or
    qt56-teamviewer but it is not installable
    Depends: qml-module-qtquick-layouts (>= 5.5) but it is not installable or
    qt56-teamviewer but it is not installable
    E: Unable to correct problems, you have held broken packages.
    [email protected]:/home/ubuntu/Downloads#

     

Sign In or Register to comment.