link icon
Ask The Community

Teamviewer too small in 4K screen

Teamviewer is impossible to use on 4K displays: the application is way too small and it makes it almost impossible to read the font. Any way to fix this?


  • ChristianCay
    ChristianCay Posts: 182 [Former Staff]

    Dear MarceloRuiz,

    Thank you for your post.

    Yes, it's possible to change DPI Settings and solve your issue. This is very handy when users have a 4K screen.

    Please run the following commands to set TeamViewer to a higher resolution

    #stop teamviewer daemon
    sudo teamviewer daemon stop
    cd ~/.local/share/teamviewer12
    #backup reg files
    cp system.reg system.reg.bak
    cp user.reg user.reg.bak
    #Replace values for LogPixels. The default value is 60 Hex. Can be from 60 to 1E0 (96 to 480 dpi)
    #The following lines updates the value to 150 dpi
    sed -i 's/LogPixels"=dword:00000060/LogPixels"=dword:00000096/' system.reg
    sed -i 's/LogPixels"=dword:00000060/LogPixels"=dword:00000096/' user.reg
    #start teamviewer daemon
    sudo teamviewer daemon start
    #start teamviewer
    teamviewer &

    Hope this solution works for you.

    If you have any other questions please don’t hesitate to contact us.


    Best regards,


    Did my reply answer your question? Accept it as a solution to help others, Thanks.
  • stormense
    stormense Posts: 3

    Bigger Window but the text is still to small.

  • stormense
    stormense Posts: 3

    This gives only a bigger window but the font/text is to small.

  • ChristianCay
    ChristianCay Posts: 182 [Former Staff]

    Dear stormense,

    Thank you for your feedback.

    May you please send us a screenshot to see the changes.

    That will help to find out a solution.


    Best regards,


    Did my reply answer your question? Accept it as a solution to help others, Thanks.
  • Thanks! The tiny font was driving me mad (using 4k2k screen on kUbuntu 17.04/Plasma), needed KMag to decode some menu items. Kudo well earned.

    Remark 1: The value 00000096 was a bit too big for me, I used 00000080 in the end.

    Remark 2: I think it would be a lot easier to have an option in the 'settings' UI to be able to set the font.

  • I am having the same problem using TeamViewer 12 on Windows 10.  Has this problem been solved in TeamViewer 13?

  • That's pretty small and exhausting to look at. :catindifferent:

  • Megui
    Megui Posts: 1

    Hello Kristian, 

    Im having the same issue in windows 10, in the HP envy, can you please give this code for windows console?


    Thank you

  • Hi,
    I'm having a similar problem with Teamviewer 14. (font scaling) on Ubuntu 18.04. when I scale my desktop to 200% (so I can actually see icons, text, etc).

    I looked in the


    no .reg files to tweak

    drwxr-xr-x  4 xxxxxxxx xxxxxxxx 4096 Oct 23 09:50 ./
    drwxr-xr-x 33 xxxxxxxx xxxxxxxx 4096 Nov 23 10:45 ../
    drwx------ 2 xxxxxxxx xxxxxxxx 4096 Nov 23 11:24 logfiles/
    drwxr-xr-x 3 xxxxxxxx xxxxxxxx 4096 Oct 23 09:50 pictureCache/

    Tried the

    [email protected]:~$ sudo systemctl stop teamviewerd.service
    [email protected]:~$ teamviewer winecfg

    does nothing (no access to dpi controls) just launches the teamviewer gui. I'm open to suggestions.



  • ka4a
    ka4a Posts: 4

    same for me. if i use scaling 200%. Please fix it.

  • ack0329
    ack0329 Posts: 40

    I guess my last post was deleted.

    As with above, no reg files for TV14 folder, and the commands don't work at all (even with changing the directory to teamviewer14 of course)

    The font is way too small in the client to even read ANYTHING without a magnifying glass!

    This is happening when Nvidia Open Source Driver is being used ... but let's not blame Nvidia or Ubuntu, because ...

    EVERY other App is working fine  ... Just NOT Teamviewer,

    Any help appreciated, I am NOT the only one with this issue

    Ubuntu 18.04 LTR, Nvidia GTX1080M 415.25 Driver, Hp Omen X Cutting Edge laptop


  • silenz
    silenz Posts: 2

    Having the same issue with a Radeon 560 card and Ubuntu 18.10. 

    [The URL link has been removed by a moderator. Please attach picture rather than putting a URL link.]

  • ack0329
    ack0329 Posts: 40

    How in this day and age could a wealthy company like TeamViewer ...

    NOT put in a Scaling and/or Font / DPI Control in the Base System or Options Tab is beyonf me.

  • silenz
    silenz Posts: 2

    to be fair to Teamviewer, I think the issue is with QT/Gnome and they can't fix it until QT does. I also having scaling problems with VLC on a 4k monitor at 200%, and there's no real fix for it either. 

    However, VLC on KDE doesn't suffer from these issues, and I would bet TV on KDE looks fine too. 

  • ack0329
    ack0329 Posts: 40

    (in Ubuntu with Nvidia) 

    One solution is to change the resolution whilst TeamViewer is running (ex to 4K) then back to 1080P, and magically the font is scaled and readable as normal

    Always trying to help, Mark

    p.s. I guess this proves it is a scaling issue, though who is the culprit?

    TeamViewer? Nvidia? or Ubuntu?  My guess is it is TViewer with Nvidia

  • I am using Kubuntu 18.10 with a 4K monitor. Font DPI is 144 and scaling is set to 1.5 and teamviewer gui is messed up with text and buttons misaligned, etc. I had similar problems with another application that shipped its own QT libraries that didn't pick up the system setting. I suspect that teamviewer ships with old static QT libraries. The proper solution would be to use the system libraries, but that has other complications.

    I added the line 'export QT_SCALE_FACTOR=1.33' to the beginning of /usr/bin/teamviewer and this "fixed" the display by scaling it to 2x for the teamviewer app (1.5X1.33 ~ 2). It isn't a real solution, but an acceptable workaround. I hope this is helpful.

  • sennah
    sennah Posts: 1


    I had the same issue and even my QT Creator was having problems. In the community over there I got the hint to put following lines on top of the startup script:

    export QT_SCALE_FACTOR=1

    I did this for teamviewer as well and it helped.

    My teamviewer script (arch linux) is located here:

    /usr/bin/teamviewer -> /opt/teamviewer/tv_bin/script/teamviewer
  • kscherer
    kscherer Posts: 3

    Thanks for this sennah! There are many options for QT and with multiple screens it gets even more complicated. I wish there was a simple answer but because everyone has a slightly different setup, we each have to experiment with these settings to find what works. Here is a link to the QT High DPI documentation for those who want to understand all the options:

  • It is larger again after this worked for many months and stopped for many more maonths but ...

    ... for  whatever reason

    this which was working from 50/2019-11/2019 and stopped working from 11/2019 to 01/2010

    is working now!

    lets hope it keeps working this time 

    So to get the fonts bigger in Linux

    sudo gedit /usr/bin/teamviewer

    and add this line to the bottom 'with single quotes'

    'export QT_SCALE_FACTOR=2.00'

    (or larger ... 2.00 works well with mine)


  • ack0329
    ack0329 Posts: 40

    Yep and 2 days later same machine same edited file and small font again oh well

  • ack0329
    ack0329 Posts: 40

    4 days later still miniscule font

    even after receiving a BADGE!

    and yes I edited the file in the next command

    sudo gedit /usr/bin/teamviewer

    and added

    'export QT_SCALE_FACTOR=2.50'

    but still problem persistes

  • kscherer
    kscherer Posts: 3

    I am now running Ubuntu 19.10 and when I ran teamviewer the fonts were small. It turns out that when the teamviewer package is upgraded (and it gets upgraded often) my earlier changes to /usr/bin/teamviewer were overwritten. So it seems to be necessary to keep adding the 'export QT_SCALE_FACTOR=1.33' line at the _beginning_ of the /usr/bin/teamviewer file. Setting this environment variable must be done before tvw_main file is sourced in order for it to passed the teamviewer program. Here are the final contents of my /usr/bin/teamviewer:

    export QT_SCALE_FACTOR=1.33
    TV_SCRIPT_DIR="$(dirname "$(readlink -e "$0")")"
    source "$TV_SCRIPT_DIR/tvw_main"
    Main "[email protected]"
  • ack0329
    ack0329 Posts: 40

    Nope no joy

    But for others with this issue ... 

    When it was working for me 

    this line haqd single quotes around it and was at the end of the file 

    export QT_SCALE_FACTOR=1.33

    I find it interewsting that you have it working with it without single quotes qand at the beginning of the file

    Either way not working AGAIN with mine!