link icon
Ask The Community

nginx 403 error -

Clicking on on the download page redirects to and displys a mostly blank "403 forbidden"  page.

FF74, Ubuntu 19.10 (that should not brake the website) 



  • PeterBrunner
    PeterBrunner Posts: 66 Staff member 🤠

    Pls. ignore the *tvcdn* link and use the other one directly from the homepage. It gives you the download for the OS in use (and supported). provides you all provided platforms with their downloads / store links.

  • pmueller_plrp
    pmueller_plrp Posts: 3 ✭✭

    Having the same problem on my Linux workstation (Ubuntu 18.04) while tying to download the clients for distribution.

    The URL doesn't matter, as your download page immediatly tries to provide the download for the recognised operating system.

    If this doesn't work, there must be a fallback to a download page which provides all download options.

    I verified this by switching my Browser User Agent to "Windows Firefox".

    Pls. turn it off and provide a download page which only presents a link for the recognised OS, but shows other options too in case of a unsupported or unrecognised OS.

  • pmueller_plrp
    pmueller_plrp Posts: 3 ✭✭

    Just tried another download:

    Even by switching my Browser User Agent to "Windows Firefox", the download buttons always provide the Windows client, even if I select MacOS.

    Seems the OS recognition or the page itself is a little bit messed up ;-)

  • I have the same error. I am running OpenSuse 15.1 with KDE and Firefox.

    If I try the teamviewer download page I am offered the Window dowload. However when I click on it I am directed to: this gives me a certificate error and when I tried to bypass this I got the nginx 403 error - message.

    If I try to access a meeting the download button there gives me an nginx 404 message.

    Havs Teamviewer been hacked? Has a certificate been allowed to remain while being publicly revoked?

  • tonygruz
    tonygruz Posts: 1 Newbie

    Nginx 403 Forbidden error is a status code generated and displayed to the user when a client tries to access a part of the webserver with insufficient permissions. When nginx access a directory, it tries to index it and return the list of files inside it to the browser/client, however by default directory indexing is disabled, and so it returns the Nginx 403 forbidden error.

    Incorrect Index File

    The try_files tries the literal path you specify in relation to the defined root directive and sets the internal file pointer. If you have directory indexing off, and is having this problem, it's probably because the try_files you are using has a directory option:

    location / {
     try_files $uri $uri/ /index.html index.php;


    location / {
     try_files $uri /index.html index.php;

    Incorrectly set permissions

    This error can also result from files and directories having incorrectly set permissions. In order to resolve this , change the directories permission to 755 and the file permissions to 644 . Make sure that the user running the Nginx process owns the files. For example, set user to www-data:

    sudo chown -R www-data:www-data *

    Finally, set the directory and file permissions as:

    sudo chmod 755 {dir}

    sudo chmod 644 {files}