link icon
Ask The Community

Android Host not accepting connections

I have the latest version of Android Teamviewer host installed but each time I try to connect to the device I get a message "Authentication Rejected" . I would like to have Unattended Access to each device.


  • Reyhan
    Reyhan Posts: 276

    Dear iggles22,

    Thank you for your post. 

    Please make sure that you have installed the right TeamViewer Host-App.


    Next step is to assign the device to your TeamViewer account:


    Then you will see the confirmation, that the device is assigned to your account:


    The android host appears immediately in your Computer & Contact list


    When you logged in with your TeamViewer account you can start an unattended remote session with a double click, no further confirmation is required.


    I hope that my guide is helpful :smileywink:




    Did my reply answer your question? Please accept it as a solution to help others, Thanks.
  • Syngin911
    Syngin911 Posts: 1

    I have a SAMSUNG  phone and have installed the correct host as you have stated 

    however  when i dont have the host app open i cannot connect to the phone  is there something that i have missed ?

  • Same here, not resolved. I have two phones (Samsung Galaxy Note 3, One Sony Xperia Z3) assigned to the account, same (latest) version of Teamviewer Host (13.0.7847) and while the Samsung does not require acceptance for remote control, Sony does require "accept or reject tap. What am I missing? Moreover, it did not require it before I had to repair android installation to factory settings. Now it does. Anybody has any idea here?

  • Hi. Have you checked that the phone always keeps applications active?
    In phone settings you always have to be active and not in ECO mode.
    Also, turn off or turn on the phone should work the application and be always online.
    On the other hand, you have to check the battery consumption and that the phone does not deactivate the function due to high energy consumption.
    You should also check that when the screen goes off (sleep mode) the system keeps working.
    I can not think of anything else, even though I still have connection problems with the host teamviewer, I have to go to applications every moment and stop and rebuke it, something that is annoying, because it stops working at inopportune moments.

  • I have downloaded the host and also the htc addon.  The app tells me the device is assigned to me and taht it is ready to connect.


    But from teamviewer on my laptop in the browser I am logged in and I see the device but then when try to connect  get the message a connection is not possible to this device with this version of teamviewer

  • Cris_
    Cris_ Posts: 3

    But it doesn't work with a Windows shortcut like:

    C:\Web\TeamViewer\TeamViewer.exe -i 9505xxxxx

    Then i get a password prompt on Windows but on Android in the TeamViewer Host app i can't set a password or get a popup with a password (QuickSupport Add-On is installed).

    When i tried to set a password for the Android device in the management console and set the Windows shortcut to:

    C:\Web\TeamViewer\TeamViewer.exe -i 9505xxxxx --Password 123456

    ..TV starts on Windows and nothing more.

  • I get the same error message. Have you figured this out yet?

  • iggles22
    iggles22 Posts: 4

    I have not had any luck getting it to work.

  • I downloaded version 12 and it works, but not with the new version.

  • iggles22
    iggles22 Posts: 4

    I will give it a try and let you know.

  • JackMark
    JackMark Posts: 2

    I was able to get it going. I had to purge data and cache on android, deinstall it, and reinstall it again. This did it., not quite  sure why.

  • Cris_
    Cris_ Posts: 3
    Please tell us which version on Windows do u using exactly? Which version of Android also please?
  • iggles22
    iggles22 Posts: 4
    Using Windows 10 and Android 4.0.4 I believe.
  • Cris_
    Cris_ Posts: 3
    Öhm Windows TeamViewer version?
  • No, your suggestion did not help. Is there something else that needs to be done?
  • Josh3
    Josh3 Posts: 1
    Mine is a Cherry Mobile H220. I have the non samsung one. It says it's not possible to do a connection with this version of TeamViewer. It keeps popping up on my Computer.
Sign In or Register to comment.