teamviewer.com link icon
or
Ask The Community

Remote control: password is blank

I've installed TeamViewer (Personal use) on my Mac and a friend's Mac: both running Catalina.

My installation is fine: running TeamViewer shows the ID and the password.

When my friend runs TeamViewer, her ID is shown, but there is just a hyphen in the password box.

She has access granted to TeamViewer in System Preferences, Security, Privacy for Accessibility, Full Disck Access and Screen Recording.

How can I get her installation to show a password, so I can control it?

Thanks

Tagged:

Best Answers

  • JeanK
    JeanK Posts: 4,173 Moderator
    Accepted Answer

    Hello @AlanWilson,

    First, you need to make sure that you enabled and apply the random password in the TeamViewer options of the remote Mac.

    Once this is done, you will be able to re-generate it with the little arrow.

    I prepared a GIF that shows you how to proceed:

    Enable random password_Mac.gif

    I hope this could make it more clear.

    Let me know how it goes! ?

    Jean

    French Community Moderator

Answers

  • Many thanks, Jean. Easy when you know!

  • JeanK
    JeanK Posts: 4,173 Moderator

    @AlanWilson this is so true...

    This is why we have the Community! ?

    I hope to see you in the Community soon! ?

    Jean

    French Community Moderator
  • Jean

    Sadly that didn't work: the remote computer's password field remains obstinately blank (with just a hyphen in). There is no circle + arrow to the right of the field, so can't re-generate.

    My TeamViewer version is 15.5.3; the remote is running 15.6.7. Both on Mac OS with automatic updates on, so pretty recent.

    The remote has uninstalled TeamViewer and reinstalled: no change.

    I've got her to try all 4 options for Random Password in Preferences, Advanced: no change (Apply, Quit & run again after each change).

    I've looked through all the settings and nothing seems wrong

    I'm baffled! Any ideas?

    Alan

  • JeanK
    JeanK Posts: 4,173 Moderator
    Accepted Answer

    Hello @AlanWilson,

    First, you need to make sure that you enabled and apply the random password in the TeamViewer options of the remote Mac.

    Once this is done, you will be able to re-generate it with the little arrow.

    I prepared a GIF that shows you how to proceed:

    Enable random password_Mac.gif

    I hope this could make it more clear.

    Let me know how it goes! ?

    Jean

    French Community Moderator
  • Jean

    That worked a treat!

    Many thanks

    Alan

Sign In or Register to comment.