link icon
Ask The Community

Problem with fonts in the latest Teamviewer versions (14.6, 14.7) in Linux

I have following problem after I installed some from the debian packages - the font is not currently found, or there is some other problem, which makes the GUI nearly completely unusable:

screenshot of teamviewer maskscreenshot of teamviewer mask

. The distribution is current Debian Buster, the locale is cs. The liberation fonts are installed, but still no success, the font is substituted by something else - or this is completely different problem...

  Same result for installed version teamviewer_14.7.1965_amd64.deb or teamviewer_14.6.2452_amd64.deb

   After upgrade from stretch to Buster and upgrade from versiopn 13 to version 14 I was not able to use the software at all.


  • I found out, the problem is caused by the screen scaling option. If the screen scaling in KDE (can be set in the system settings / Screen and monitor / Change screen scale) - it the scale is set to 1, then the screen looks normally. In the screenshot above the scale has been set to 1.2

    I think, thsi problem will be in every Teamviewer version, it would be nice, if teamviewer could support also the scaling correctly, because it is important for the screens with largen resolutions, where the dialogs and fonts woudl be too small for the screen..

  • I faced the same issue and i tried others way to succeed and they are not showing the right path.

  • AstorVH
    AstorVH Posts: 2

    This has happened to me after connecting from another computer with a very different resolution (specifically macOS Catalina to Debian Buster) and the error occurred when during the connection I closed the Debian teamviewer unintentionally.

    I solved it by adjusting the two computers in very close resolutions (1024 x 768 macOS & 1920x1080 Debian) and then I repeated the operation of connecting and closing the Debian teameviewer.

    Then, simply by opening it, the fonts have returned to their normal size.


  • AstorVH
    AstorVH Posts: 2

    Detail: closing the teameviewer in Debian from macOS .