Community Manager

Hi all,

We would like to announce that as of February 18th, 2020, Blizz will no longer be actively supporting macOS 10.12 operating system for upcoming Blizz releases.

Stopping the active support of an operating system means that no updates or fixes which are specific to these operating systems will be implemented and Blizz versions newer than Blizz in version 15.2 won´t be compatible with these operating systems.

For those who are running macOS 10.12 as an operating system:

You can update your macOS to a newer version and continue using Blizz with the latest version.

Alternatively, you can still use Blizz up to version 15.1 if you are running macOS 10.12.

We generally recommend to only run current operating systems and software versions. So please make sure to update to the most recent version of macOS to also get the latest Blizz version.

To see a full list of our supported operating systems by Blizz, please see our Knowledge Base article here: https://community.teamviewer.com/t5/Blizz-Knowledge-Base/Which-operating-systems-are-supported-for-B...

We thank you for your understanding.

Best,

Esther