Highlighted
Posted by
Henagon

Disabling Main Window Popup on remote PC after starting remote connection

TeamViewer has a built-in feature which automatically shows the main TeamViewer window on a remote target after a local PC enters the target's ID, even if it's minimized. I assume this is to make it easier for the person on the target PC to provide the password to the connecting user. This is undesirable for my use-case. Is there a way to disable this? I have gone through all settings and advanced settings and couldn't find anything to disable this behavior.

Thanks for any help/suggestions!

3 Replies
3 Replies
Highlighted
Posted by Moderator Moderator
Moderator

Re: Disabling Main Window Popup on remote PC after starting remote connection

Hello @bmx6306,

Thank you for your message. 🙌

Unfortunately, it is impossible, for security reasons, to disable this.

Best,

Jean

French Community Moderator

If my reply answered your question, help out other users and click the Accept as a Solution button below. ✅
You can also say thanks by clicking on the Thumbs Up button!
Thanks for being an active member of our Community!

Highlighted
Posted by
Henagon

Re: Disabling Main Window Popup on remote PC after starting remote connection

@JeanK thanks for your response. For what security reasons exactly?

Please ignore/delete my previous response as I didn't reply directly to your post or @ you.

Highlighted
Posted by Moderator Moderator
Moderator

Re: Disabling Main Window Popup on remote PC after starting remote connection

Hello @bmx6306,

Unfortunately, I cannot tell you the exact specific reason.

I can only tell you that this was a security-related decision.

Best regards

Jean

French Community Moderator

If my reply answered your question, help out other users and click the Accept as a Solution button below. ✅
You can also say thanks by clicking on the Thumbs Up button!
Thanks for being an active member of our Community!