Highlighted
Posted by
Henagon

Re: Turn off unattended access

I used TeamViewer a year or so ago and I thought the default installation was the the Client/Pal you are helping had to let you in (accept you the Server/Controller).

The other day I set a pal up with teamviewer and he said that I just connected and that he had no warning that I was connecting.

Obviously we exchanged ID and Password over the phone.

He should have been warned that I was connecting and been given the option to refuse.

Where is the option to stop auto/unattended access?

Thanks.

 

4 Replies
4 Replies
Highlighted
Posted by Moderator Moderator
Moderator

Re: Turn off unattended access

Hello @Huntsman

Thank you for your message. 🙌

If you exchanged the password via the phone, then we are the in attended access context.

Of course you can set up unattended access and disable it. 😊

You will find all the information you need in our Knowledge Base article here: Secure unattended access to devices

You will also find all the information about how passwords work in a TeamViewer context here: All about passwords

I hope this could help. 🍀

If not, do not hesitate to ask your questions here.

Cheers,

Jean

French Community Moderator

If my reply answered your question, help out other users and click the Accept as a Solution button below. ✅
You can also say thanks by clicking on the Thumbs Up button!
Thanks for being an active member of our Community!

Highlighted
Posted by
Henagon

Re: Turn off unattended access

Thanks for your reply.

It seems I have not expressed my requirement correctly.

I have done a test using a spare PC, lets call the spare PC myPal.

When I connect to myPal via Teamviewer I get instant access to myPal, this should not happen!

myPal should get a warning that I want to connect to myPal's PC; then mPal could let me in or refuse.

Thanks.

Highlighted
Posted by Moderator Moderator
Moderator

Re: Turn off unattended access

Hello @Huntsman,

Thank you for your these additional details.

There can be two reasons why a connection establishes with a simple click to a remote computer:

  1. The personal password of PC MyPal you saved in the proprieties in your Computers & Contacts list is the same as the one set up in the Security Options of PC MyPal. In this case, you need to remove one of the two passwords:
    TeamViewer options2.png
  2. You have enabled Easy Access for connections to PC MyPal. In this case, please open the TeamViewer Options of PC MyPal, go to ExtrasOptions Security and untick the Easy Access box:
    TeamViewer options.png

 

If you want that the remote PCs you are connecting to get a warning and have to authorize your connection, you need to use the Remote control prompt for confirmation button:

3.png

Now, you should have all the information to sort this out. 🤓

If not, please let me know!

Cheers,

Jean

French Community Moderator

If my reply answered your question, help out other users and click the Accept as a Solution button below. ✅
You can also say thanks by clicking on the Thumbs Up button!
Thanks for being an active member of our Community!

Highlighted
Posted by
Henagon

Re: Turn off unattended access

That is exactly what I want to achieve. The user/MyPal should not suddenly see me messing with his/her PC. I would like MyPal to get a warning.
Is your solution on the client/MyPal side or mine/server?
I cannot see the option you show Remote control/prompt for confirmation ;(
I'm using the free version as I am only occasional user and none profit user.
Please note:-Grant easy access has never been on.
Thanks for your help so far.