Highlighted
Posted by NCSLLC
Digon

A Solution for Audio Transfer with a Mac as the Remote

Hi,

I recently purchased Teamviewer to use with my recording studio computer so I could do accoustic work from my office. I didn't do enough research and then discovered that Teamviewer can't transmit audio from the remote if it's a Mac computer. While I was looking for a solution I missed my 7 day refund period.

After awhile thinking on my problem I've come up with a kind of solution. Rather than using Teamviewer to transfer audio my solution is to use applications like Skype or Discord. By having both computers in a call on Discord I then set up my computer to have it's audio output routed to Discord as an audio input so that it will send audio through the 'call'. So far it's worked fairly well but there may be a bit of latency.

In order to achieve this I used an application called Loopback by Rogue Amoeba. There's a tutorial on how to use it on their website and in the app. But here are some photos on what I've done

Settings within Logic Pro X:

Screen Shot 2018-03-27 at 12.32.03 PM.png

Setup in Discord:

Screen Shot 2018-03-27 at 12.33.58 PM.pngThis can be done with other applications too and with the system audio in general.

Hope this helped anyone trying to figure out how to listen to a Remote Mac Computer's audio and if there are better solutions out there please let me know!

1 Reply
1 Reply
Posted by craoub
Photon

Re: A Solution for Audio Transfer with a Mac as the Remote

I have found another solution that works very well without having to use Skype, etc. However, it is pretty kludgy to setup, but works perfectly thereafter.

First, I install the "Soundflower" virtual audio device (available for free from GitHub) on the computer I am remoting into. I'm sure Loopback would work also (presumably an easier install with more functionality, but costs $99). Make sure you read the installation notes carefully.

On the computer you will be remoting into, start teamviewer and configure the audio settings (via the audio tab in the preference screen) so that the soundflower (or loopback) virtual device is chosen for the microphone device. This should only have to be done once.

Every time you remote in and want sound, you should also select the soundflower device to be the default audio output (done via the speaker icon on the apple menu bar). Note that when this is selected, you will hear no audio output on your physical remote machine, so don't forget to change the audio ouput device back when you are done remoting in.

Once you are successfully remoted in, you must turn on voice over ip and unmute the microphone. For whatever reason (perhaps security?), this last step of unmuting the mic is not possible without introducing a tricky workaround.

To turn on voice over ip, select the headset with mic icon in the blue teamviewer control box ON THE REMOTE MACHINE. This will be in the upper right part of your screen. This will open up an audio section. If you are able to view the physical screen of the remote computer, you would see two icons in this opened up section. The first icon is a mic that allows you to toggle the mic on or off. This part of the section that has these two icons is blacked out (again, maybe due to security?) on the teamviewer's version of the remote screen. Clicking where you know the mic icon is doesn't work either.

Here is one solution I found that works around this issue. There are others. As I have previously purchased the “keyboard maestro” product (which I love), I used it. Basically, I setup a keyboard macro that will click the area of the screen where the microphone icon resides. I then invoke this macro remotely (I chose control-a)  and, voila, I now have sound!

I'm sure there are a bunch of other ways of accomplishing the same click. I would have used Apples’s free and included Applescript had I not already owned “keyboard maestro”.