Highlighted
Posted by ang52
Digon

Disable automatic password on remote login

Earlier versions of TeamViewer needed a password entered whenever I remotely accessed my home computer from my laptop.
The last 2 versions have not shown anything about password entry, just access my PC as soon as I click "connect".
I have searched the manual and Help and found no information about this.
I changed my password and caused "password entered is invalid" so I had to enter a password every time.
I then removed all the passwords, unticked "keep signed in" and when I tried to access remotely again, the login box came up with the password entered and I only had to click "login" to gain access. I cannot find where I can select "enter password every time", which must have been an option in earlier versions.
Community has a similar question on Disable "Keep signed in" but this does not really solve my problem, and its solution was to create a feature request

If I lose my laptop and someone gains access to it, they have easy access to my PC.

 

9 Replies
1 Accepted Solution

Accepted Solutions
Posted by ang52
Digon
Solution

Re: Disable automatic password on remote login

I have finally cracked it - open the device you are using to make the access to the other device.

Go to Extras/Options/Advanced and click to open Advanced Settings. scroll down to Advanced Settings for connection to OTHER computers and untick Temporarily Save Connection Passwords.
I think the confusion in the solutions provided before is which device  you are looking at Extras/Options etc on - for this it has to be the one you are using to connect to the other device.

9 Replies
Posted by Senior Moderator Senior Moderator
Senior Moderator

RE: Disable automatic password on remote login

Dear @ang52

Thank you for your post.

If the clients are assigned to your TeamViewer account, you are able to start a session to a client without any personal password. You make the authorisation with your TeamViewer credentials.

Password_2.JPG

If a client is assigned to your account, the settings on the client side looks like this:

Password_4.JPG

If  you like to enter password by every connection, you could change the settings. 

Please first remove the assignment to your account and add a personal password on the client side.

Like this:

Password_3_2.jpg

Now you have to enter a password by every connection.

To make your feel better, I recommend you to log out, if you do not need TeamViewer.

Hope it is helpful for you. :smileyhappy:

Did my reply answer your question? Please accept it as a solution to help others, Thanks.
Reyhan
Posted by tagger5
Photon

Re: RE: Disable automatic password on remote login

Hi, i tried to do exactly that, but it will only ask for a password one time. After i put the correct one, it will automatically connect every other session.

I want to have a password protection on every single computer i have in my account, and it needs to be prompted every single time. If someone uses my computer they automatically have access to all my other computers on my teamviewer account. Wich is a major security issue. 

Posted by kan
Photon

Re: RE: Disable automatic password on remote login

Agreed.

Should allow to disable  automatic password on remote login.

Current this is not the case.

Posted by roandr
Photon

Re: RE: Disable automatic password on remote login

You should also be allowed to set this on the HOST side as well. What good is this option if it's only usable on the CLIENT side if several different teamviewer accounts connects to the same HOST.

I'n my case I want every CLIENT that connects to a specific HOST to be asked for the password whatever CLIENT settings are set.

If not I don't see how teamviewer can be used as a tool for managing ex. remote servers. If one of the teamviewer CLIENTs that connects to the HOST is compromized the HOST is also compromized.

Posted by kleinash
Henagon

Re: RE: Disable automatic password on remote login

This is just what I needed. I don't want to have to put in a password every time I log in. If for some reason this does not work and it asks me for a password is there a way to get it via the online listing of devices. Basically to make sure I am not locked out of my remote device? 

Posted by JeremyL
Photon

Re: Disable automatic password on remote login

Janky workaround:

Enter an incorrect password and attempt to log in. It will fail and ask you to re-enter. Hit cancel. It now "remembers" the wrong password in the autofill and others won't be able to log in.

A bit of a chore to remember to do this after ending your session, but works in a pinch. Should really be an option to disable the autofill.

Posted by kleinash
Henagon

Re: Disable automatic password on remote login

Thx

Posted by Pixielay
Henagon

Re: Disable automatic password on remote login

This one works for me.

 

In the contact book, select your computer and go to properties of that computer.

In there, you will see team viewer ID, password, alias and group blablabla.

In the password field, enter the wrong password, something like aaa works.

 

Now, It will ask you for correct password everytime, since automatic password is incorrect.

Hope it will help you too.

Posted by ang52
Digon
Solution

Re: Disable automatic password on remote login

I have finally cracked it - open the device you are using to make the access to the other device.

Go to Extras/Options/Advanced and click to open Advanced Settings. scroll down to Advanced Settings for connection to OTHER computers and untick Temporarily Save Connection Passwords.
I think the confusion in the solutions provided before is which device  you are looking at Extras/Options etc on - for this it has to be the one you are using to connect to the other device.