Posted by SupportPanacea
Henagon

Prevent ""No connection to TeamViewer server" pop-up.

I am trying to prevent the following popup window from appearing when there is no internet connection:

"No connection to TeamViewer server. Please check your internet connection. Most likely you use a proxy server and you have to enter the proper information in the options dialog"

Does anyone know how to permanently prevent this?  Initially we thought changing the Proxy settings option to "No Proxy" would prevent it but it does not.  Thanks.

15 Replies
Posted by TeamViewer Staff
TeamViewer Staff

Re: Prevent ""No connection to TeamViewer server" pop-up.

Dear SupportPanacea,

There is a way to do what you are asking.

Open the regedit and navigate to the following path.

HKEY_Current_User/Software/TeamViewer/MsgBoxDontShow

Once here create a new key Dword 32, then name the key “NoConnectionAvailable” and set to decimal value 1.

This should disable that specific popup box.

Regards,

 

Aaron Boshers
Support Engineer

If my reply answered your question, help out other users and click the Accept as a Solution button below.
You can also say thanks by clicking on the Thumbs Up button! Thanks for being an active member of our Community!
Posted by lgray2328
Henagon

Re: Prevent ""No connection to TeamViewer server" pop-up.

How would I do this in Windows 10 home?

Posted by lgray2328
Henagon

Re: Prevent ""No connection to TeamViewer server" pop-up.

Nevermind. I figured it out. Thanks for the tip!

Highlighted
Posted by zeus
Electron

Re: Prevent ""No connection to TeamViewer server" pop-up.

Dude.. if you figured out - please share. We come to this thread only to discover that you figured it out!! :)

1 Reply
Posted by TeamViewer Staff
TeamViewer Staff

Re: Prevent ""No connection to TeamViewer server" pop-up.

Dear Zeus,

Thank you for participating on our community.

Please refer to my post above, it includes the directions on how to do this. 

Best Regards,

 

Aaron Boshers
Support Engineer

If my reply answered your question, help out other users and click the Accept as a Solution button below.
You can also say thanks by clicking on the Thumbs Up button! Thanks for being an active member of our Community!
Posted by alikatal
Henagon

Re: Prevent ""No connection to TeamViewer server" pop-up.

Hi,

I can not find this path in windows 10.

Posted by ashupp
Neutron

Re: Prevent ""No connection to TeamViewer server" pop-up.

On Windows 10 IoT Enterprise 64 Bit LTSB 2016 the following command did the trick.

reg add "HKCU\Software\TeamViewer\MsgBoxDontShow" /v NoConnectionAvailable /t reg_dword /d 1 /f

 

Posted by smgkc
Henagon

Re: Prevent ""No connection to TeamViewer server" pop-up.

Is there any way to do this on Linux/Ubuntu 18.04?

Posted by Max_Spindel
Digon

Re: Prevent ""No connection to TeamViewer server" pop-up.

Is there a LOCAL MACHINE key for this? 

I ask because I have a series of media player that plays content regardless if there is a network conection or not, that cannot have this message popping up everytime it losses network. That said this media player uses our clients 3rd party software to play their content, this software during configuration generates its own user profile. The created user has no UI when logged into it, and it only launches the player software and bg services (such as teamviewer host) the UI is suppressed however meaning I cannot get to regedit on this user, making it impossible for me to add this key. 

A LOCAL MACHINE key that serves the same purpose would solve my problem I am hoping something like this exists and that you might be able to point me in the right direction.

Currently my only option has been to manually disconnect the unit from network and wait till the message appears and check off do not display however this VERY tedious to do when I am in the middle of mass production of 30 units  I hope you can help me find a solution for this as doing this manually leaves me open for someone to make a mistake and have this pop onsite for the client if that is the case I would have to spend hundreds in a service call to literally check a box I really want to avoid this.

Posted by sirchadwick1
Henagon

Re: Prevent ""No connection to TeamViewer server" pop-up.

I'm looking for a HKLM solution as well.  For now, I'm testing simply adding the same MsgBoxDontShow  folder and dword to the same path under HKLM to see if it works.

How have the TeamViewer developers not created an option within the settings of the software to supress this yet?  It's extremely annoying and frustrates us and customers alike.

Posted by Max_Spindel
Digon

Re: Prevent ""No connection to TeamViewer server" pop-up.

I can confirm the HKLM key mentioned above does work I ended up loading the Hive of the targeted user and injecting the key + value in during my automation process I havent had an issue since.

Please note in the Registry hive under your PC there are no real folders persay the correct terms are "Root Keys" (such as HKLM), "Keys" (such as "MsgBoxDontShow") and "Values" (your actual value and type of value such as Dword) this is just an FYI to  avoid any confusion it is always best to use the correct industry terms when asking for help

Posted by sirchadwick1
Henagon

Re: Prevent ""No connection to TeamViewer server" pop-up.

Thanks.  What is the exact script you had to run to get it to work properly under HKEY_Local_Machine?

 

Posted by sirchadwick1
Henagon

Re: Prevent ""No connection to TeamViewer server" pop-up.

Also, I never could get this popup suppressed even under HKEY_Current_User.

This has been frustrating.

Posted by Max_Spindel
Digon

Re: Prevent ""No connection to TeamViewer server" pop-up.

No script is needed.... I made one for my purposes but my situation was unique I wasnt able to access the user directly when I was working with my scenario. In essence the reason I had a script was for automation not because its needed. You an also add this manually via regedit. 

Before trying below, based on your replies so far  it really sounds to me like you are not very familiar or comfortable with using regedit or registry keys at which point I am going to give this warning: you can brick your computer editing things incorrectly in the regedit so do the next part at your own risk!

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\BSP\Software\TeamViewer\MsgBoxDontShow] "NoConnectionAvailable"=dword:00000001

NOTE: this is the contents of the key and value exported from MY regedit to a .reg file  you cannot just copy and paste this and expect it will not work as your PC will most likely not have a "BSP" user to use nor will it be the user thats receiving the pop up. However you can use Notepad to create your own .reg file based the above export. To make it work for you, you will need ot know your Hive path (the path will look largely the same as above in my key path most likely just the ".../BSP/..." portion will be something else for you) . Once you have edited the path save this file as a .reg file once done double click the file and a warning will pop up letting you know your about to add a key to your registry. However if you did things correctly the key will now be showing up in your regeditor under the same location as indicated in the .reg file you created earlier in this process, as well the pop up should go away. I would also recommend restarting the PC prior to testing to ensure that the application had a chance to collect the new setting.

Hope thats helpful,

Cheers

Maximilian

 

Posted by smgkc
Henagon

Re: Prevent ""No connection to TeamViewer server" pop-up.

Any tips for doing this in Linux? Preferably 18.04