Posted by Spiralstair

Remote access problems

I am trying to sometimes gain access to Mac which is constantly on. The Mac has a security password and screensaver turned on - the screen goes to sleep after 5 mins but the processor is working on graphics processing.

I try and login remotely and it lets me login for about an hour after leaving the computer (I am promoted to enter my password) and then after about an hour when I try and login it takes me to the password lock screen of the Mac I enter the password and then nothing happens. I cant gain access any more. I'm locked out completely. Meanwhile the Mac is still running fine.

I'm running the newest version of TV. I have assigned the iMac as one of my computers in my account. Do I need to disable the Mac password? I want to avoid this if possible.

Are there specific settings in TV I need to address?
Many thanks
3 Replies
Posted by DesignCorp

Re: Remote access problems

I've had similar situations but for me it's usually at initial remote login. My work-around is to login and then when the remote screen goes blank, I close the remote session. Then open it again. It asks for local credentials again, but it usually shows the desktop the second time. 

I don't know, but wonder if the "grant easy access" option in the TV client would prevent this. 

I've also had situations where the remote screen does not show the login or password field... but I've managed to key the correct sequence blindly and it logs in and then shows the remote screen. 

Posted by TeamViewer Staff
TeamViewer Staff

Re: Remote access problems


Yes, this is a known issue with Macs currently. Undortunately, we are still fixing this issue. Until the fix has been released, you will need to turn off the lock screen on the device. The developers are working for a resolution to this information so hopefully it will be sooner than later.

1 Reply
Posted by DesignCorp

Re: Remote access problems

That’s a major issue for me, as I support hundreds of Macs at many different locations remotely. But at least I now know it’s a known issue.

Do we need to set the “lock screen" setting on the remote side for every machine? If so, how?  Or is that just the single setting on my end under Actions> Lock Computer> Lock on Session End?