Posted by cbrandolino
Photon

Troubleshooting Teamview Update - Username / Password Incorrect?

I was notified by the TeamViewer12 Application that an update was available, but I am having trouble installing this update. When I start the update process, a TeamViewer window pops up and I'm prompted to: "Please enter your administrative username, password and domain". Under the "Username" field, "Administrator" auto-populates. I've entered the password I've always used for TeamViewer to no avail. I even tried creating a TeamViewer account, signing in to that, and making sure all my passwords are the same. I'm not sure what I'm doing wrong?

Please note that I am trying to update TeamViewer on my laptop. This all started because a few days ago I tried to remote in to my desktop and was given an error that TeamViewer was not running on my remote computer (oddly, because I use it all the time). When I got home, I double checked that my desktop was in fact on (it was), so I thought that updating my desktop TeamViewer12 would help. It did not. I was able to update my desktop to the latest version without the "username/password" prompt, very easily. Of course now, I cannot connect to my desktop because my desktop is running the v13, and my laptop has v12.

If anyone knows how I can get this update put onto my laptop, I would greatly appreciate it!