Highlighted
Posted by
Photon

Enable teamviewer daemon ubuntu

Teamviewer 12

Ubuntu 

I have succesfully installed teamviewer on ubunty, but when i start it, it says the deamon is not running.

So i tried:

sudo teamviewer --daemon start 

But it says the daemon is already running, and the request will be ignored.

So i tried to stop it first, and than start it again. Nope

Tried enable instead of start, didn't work either..

Anny other ideas?

2 Replies
2 Replies
Highlighted
Posted by
Photon

Re: Enable teamviewer daemon ubuntu

sudo teamviewer --daemon enable 

 

this should work!1

Highlighted
Posted by
Photon

Re: Enable teamviewer daemon ubuntu

Hello! i wanted to add to this as i had a weird case causing the OP message to occur regardless of daemon status.

 

IF:

sudo systemctl enable teamviewerd.service

has been manually invoked prior to

sudo teamviewer daemon enable

 

then simply enabling daemon will not work.

fix:

1. sudo systemctl disable teamviewerd.service

2. sudo teamviewer daemon enable

---

the output is the same but it will allow teamviewer to manage the service - otherwise it fails silently.