Posted by Vishal
Photon

Getting error "A connection could not be established. Reason unknown"

Hello Evenryone, 

I am using Teamviewer 12 on Ubuntu 16.04 , while connecting to some of the host machines running same version of Teamviewer , I get "A connection could not be established. Reason unknown" error. 

This is shown even after many a attempts and when both the machines i.e. host machine and mine have been restarted. 

Please note that I am able to connect to other machines running Teamview 12! 

Looking forward to a solution. 

Thanks in advance 

Regards  

Vishal 

10 Replies
Posted by TeamViewer Staff
TeamViewer Staff

Re: Getting error "A connection could not be established. Reason unknown"

Dear Vishal,

Thank you for your post.

This message might be shown because of many reasons.

For example, connection issues, the computer is not responding, etc.

Have a try by disabling UDP when you have this issues.

Could you please test whether deactivating UDP (Extras->Options->Advanced->Show Advanced Options->Advanced Network Settings->uncheck "Use UDP (recommended)") solves the problem?

For performance reasons, please remember to reactivate this option if the problem can not be solved this way.

Thank you very much in advance.

 

Best Regards,

Christian

Did my reply answer your question? Accept it as a solution to help others, Thanks.
Posted by walldoo99
Henagon

Re: Getting error "A connection could not be established. Reason unknown"

I think a lot more people are having this issue and can't find this post

Posted by MGogulapati
Digon

Re: Getting error "A connection could not be established. Reason unknown"

I am seeing this error for the first time, after upgrading my personal computers to Version 13.  I couldn't find a solution nor troubleshooting steps. Even after reinstalling the software (same version) on both computers, the problem remained the same.  

A solution or troubleshooting steps would be much appreciated.  - MG

Posted by TeamViewer Staff
TeamViewer Staff

Re: Getting error "A connection could not be established. Reason unknown"

Dear MGogulapati,

Have you tried disabling UDP?

Another solution is force TeamViewer to work on outgoing port 80.

On Linux, open your choice of a file editor and add the following line in the global.conf file that can be located here: /opt/teamviewer/config/global.conf

First, stop the daemon with the command

sudo teamviewer daemon stop

Then add the following:

[int32] AllowedConnectionProtocols = 3

After this, please restart the TeamViewer daemon

sudo teamviewer daemon start

In Windows, do the following, please open the regedit on the machine, and navigate to the path below:

32 bit: HKEY_LOCAL_MACHINE\SOFTWARE\TeamViewer\
64 bit: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\TeamViewer\

Create a new DWORD 32 registry key, and name it AllowedConnectionProtocols with the decimal value of 3 and restart the device.

Thank you in advance and I look forward to hearing from you.

Did my reply answer your question? Accept it as a solution to help others, Thanks.
Highlighted
Posted by walldoo99
Henagon

Re: Getting error "A connection could not be established. Reason unknown"

why would we have to edit the register in windows? I can understand having to just through hoops in some linus distros, but not windows or apple.

I find it interesting that this problem is so wide spread, but if I run my VPN, no problems connecting. hmmm

Posted by Greenacres
Electron

Re: Getting error "A connection could not be established. Reason unknown"

I am getting the same error on upgrading to version 13

Posted by MGogulapati
Digon

Re: Getting error "A connection could not be established. Reason unknown"

Sorry, I couldn't help with changing registry settings on Version 13.   

I have downgraded teavmviewer to Version 12 all my computers, and the problem was resolved.   I had to restart computers couple of times though. 

I am sure, the connectivity issues are related to new secuirty settings in Version 13.  I will wait for more stable version. 

MG 

Posted by htennek2k
Henagon

Re: Getting error "A connection could not be established. Reason unknown"

Hello folks.

I usually use TeamViewer as a PhD Student to connect from my lab computer (iMac) to my home computer (Windows 8 Laptop). Had this problem this morning. 

I got it solver by upgrading TeamViewer in both machines. I'm lucky my wife was home.

So, hopefully this will be the case for all people having this issue.

Good luck!

Posted by MGogulapati
Digon

Re: Getting error "A connection could not be established. Reason unknown"

I am glad it is working for you on Windows 8.   

Teamviewer 13+ connectivity is intermittent to/from Windows 10 with IP-V6 computer. 

All my computers are on Windows 10 with IP-V6 enabled.   As of now, the only workaround for making the teamviewer (version 13+) connectivty work is to "Disable IP-V6 either on source or destination computer" .    I am not sure, when teamviewer is considering to support IP-V6.   

MG

Posted by JamesHH
Photon

Re: Getting error "A connection could not be established. Reason unknown"

This worked for me. I was having the issue between two Ubuntu machines.

However, stopping and restarting the daemon was all that was needed. The config option wasn't necessary.