Announcements

Shape the future of TeamViewer with our Product Team. Click here to join!

Posted by tkintenn
Henagon

Opensuse Leap 15 teamviewer 12 doesn't open

It worked on Tumbleweed changed to leap 15 and now it won't open. I

Leap 15, Gnome 3.26.1 fresh install. I've switch to Xorg and disabled wayland (which broke GDM). Nothing has worked.

Is there something else that needs to be done?

3 Replies
Posted by mwelwarsky
Photon

Re: Opensuse Leap 15 teamviewer 12 doesn't open

Same problem here, fresh installation with KDE Plasma 5. Same issue.

Posted by MarkusHeberling
Henagon

Re: Opensuse Leap 15 teamviewer 12 doesn't open

I have the same problem.

What does work for me is, to download the Windows Portable Version and run that with wine. I can do remote control incoming and outgoing with that. Also I can join meetings. Unfortunately I can't create a presentation meeting. Always get "Authentifizierung gescheitert" when I try to do that. If I am a participant in a meeting and someone makes ma a presenter the application crashes.

So if you only need the remote control options or passively join a meeting, use the windows portable version with wine. If you need to host meetings, you're out of luck at the moment...
Highlighted
Posted by achilles
Neutron

Re: Opensuse Leap 15 teamviewer 12 doesn't open

I have confirmed this works for TeamViewer 12.0.93330:

1. Fixing the font library issue:

Download libfreetype6-32bit 2.6.3 from the Leap 42.3 repository here. Extract libfreetype.so.6.12.3 to /opt/teamviewer/tv_bin/wine/lib/libfreetype.so.6

Note: Using the Arch freetype library mentioned in this post does not work.

2. Fixing the libxcb issue:

Download libxcb1-32bit 1.11.1 from the Leap 42.3 repository here. Install the rpm with 

# rpm -i --force libxcb1-32bit.rpm

make sure you lock libxcb1-32bit in Yast so it does not get updated.

Alternatively you can keep libxcb1-32bit 1.13 but you need to recompile it with CFLAGS="%depflags -O1" in the specfile. I have not tried it yet but compiling the library for 32bit on 64bit systems does not seem trivial.