Posted by mcdragon
Digon

Problems setting up WoL on Ubuntu

I have been having problems getting Wake on LAN to work on my Ubuntu PC. I have troubleshooted a few things and it seems I just cannot get TV to send the correct signal to the PC. I can make my Vigor router wake the PC though its built-in WoL tool.

The version I am running is v12.0.76279 however I read that there might be some improvements in the next version however these seem more targeted towards Raspberry Pi.

My ethtool command returns Supports Wake-on: pg

I have oopened up port 9 completely to redirect to the static IP address of the Ubuntu PC. Port scanning times out but I think this might be because it cannot detect it if the PC is shut down.

If the PC is on port scanners return port 9 as closed.

Any suggestions?

 

3 Replies
3 Replies
Posted by TeamViewer Staff
TeamViewer Staff

Re: Problems setting up WoL on Ubuntu

Dear mcdragon,

Thank you for your post.

It's a good sign that your router wakes your computer.

UDP is connectionless, so it's difficult to check if the port or service listening on it is available.

In this case, we suggest you change port forwarding configuration to redirect to your network address instead of your computers IP address.

Have a try on that one and let us know if it works for you.

 

Best regards,

Christian

Did my reply answer your question? Accept it as a solution to help others, Thanks.
Posted by mcdragon
Digon

Re: Problems setting up WoL on Ubuntu

Hi

Apologies for the late reply but I didn't see any reply notifications.

How exactly would I "redirect to your network address". I thought you could only redirect to a fixed IP address.

This is a screenshot of my routers port forwarding interface.

Screenshot from 2018-06-12 18-38-16.png

Posted by mcdragon
Digon

Re: Problems setting up WoL on Ubuntu

Was told that the image in my previous post contained private information and was removed. I can still see it and anyways, an internal IP address is not private data. It just means it identifies a computer inside my internal network as is not visible from the outside. It would have been different if I disclosed my public IP address which could be considered private.

I thought you of all would understand that. Anyways, any possible replies relevant to my question perhaps??Screenshot from 2018-06-12 18-38-16-edited.png