Announcements

Shape the future of the TeamViewer product with our Product Team. Click here to join!

Posted by Martin-Ng
Photon

TV 12 does not connect to Master-Server only to localhost

Hi all,

As I'm actually away, I tried to launch a new TV session via cli and connect with my Android Client afterwards.
This didn't work as I always got the message that the remote machine is not running Teamviewer at all ...
Checking the teamviewer status shows it up an running, plus providing me with the current ID ...
I restarted the daemon and even the TV instance ... still no luck ...
The service is running ... but never connects ... There is no Firewall inbetween - no proxy ...
From netstat I can see that it establishes a connection to localhost, but not to the master-server ... hence it doesn't announce its presents - hence TV tells you the machine isn't online ...
currently rebootin the box is a bad idea as some important jobs need to finish first ...

Any ideas ?

I'm running TV 12.0.71510 on Ubuntu 16.4 (64bit)
the Master-server is reachable via http/https ...
1 Reply
Highlighted
Posted by TeamViewer Staff
TeamViewer Staff

Re: TV 12 does not connect to Master-Server only to localhost

Dear Martin-Ng,

Thank you for your message.

If you're able to reach TeamViewer using port 80 please use the following instructions to fix your issue.

First, stop the daemon with the command:

sudo teamviewer daemon stop

Please open your choice of a file editor and add the following line in the global.conf file that can be located here: /opt/teamviewer/config/global.conf and add the following:

[int32] AllowedConnectionProtocols = 3

After this, please restart the TeamViewer daemon:

sudo teamviewer daemon start

In case you have any further problems after this change, please contact us again and send us the new log file by running the following command:

sudo teamviewer ziplog

Thank you in advance and I look forward to hearing from you.

 

Best regards,

Christian

Did my reply answer your question? Accept it as a solution to help others, Thanks.