Highlighted
Posted by fitzgerm
Electron

TeamViewer install on Ubuntu 18.04 - unable to connect

Hi,

 

I have installed TeamViewer 14 on Ubuntu server 18.04 and the porcess is running, I have ID and assigned to account with password.  However when I try and connect, it fails.  Screen shows initializing diaplay and the following in my teamviewlogs :

2019/04/10 12:31:36.885 22584 **Please do not post TeamViewer IDs**78880 DF!! InitDesktop failed, waiting 1 second, Errorcode=22
2019/04/10 12:31:36.925 22584 **Please do not post TeamViewer IDs**78880 DF!! FB: Attaching to frame buffer device failed: 22, Errorcode=22
2019/04/10 12:31:36.925 22584 **Please do not post TeamViewer IDs**78880 DF!! InitDesktop failed, waiting 1 second, Errorcode=22
2019/04/10 12:31:36.966 22584 **Please do not post TeamViewer IDs**78880 DF!! FB: Attaching to frame buffer device failed: 22, Errorcode=22
2019/04/10 12:31:36.966 22584 **Please do not post TeamViewer IDs**78880 DF!! InitDesktop failed, waiting 1 second, Errorcode=22
2019/04/10 12:31:37.006 22584 **Please do not post TeamViewer IDs**78880 DF!! FB: Attaching to frame buffer device failed: 22, Errorcode=22
2019/04/10 12:31:37.006 22584 **Please do not post TeamViewer IDs**78880 DF!! InitDesktop failed, waiting 1 second, Errorcode=22
2019/04/10 12:31:37.047 22584 **Please do not post TeamViewer IDs**78880 DF!! FB: Attaching to frame buffer device failed: 22, Errorcode=22
2019/04/10 12:31:37.047 22584 **Please do not post TeamViewer IDs**78880 DF!! InitDesktop failed, waiting 1 second, Errorcode=22

I have searched for resolution to this and can confirm that i have the following

crw-rw---- 1 root video 29, 0 Apr 8 10:28 /dev/fb0

I get the following from dmesg

[ 0.024000] Security Framework initialized
[ 1.149590] efifb: framebuffer at 0x91000000, using 3072k, total 3072k
[ 1.166069] Console: switching to colour frame buffer device 128x48
[ 1.183255] fb0: EFI VGA frame buffer device
[ 2.964044] Console: switching to colour frame buffer device 128x48
[ 3.347916] mgag200 0000:03:00.0: fb0: mgadrmfb frame buffer device

running sudo fgconsole return 1

It seems like i have to enabled something in realtion to usingthe frambuffer console, but not clear to me what. 

Looking at this article it should be possible https://community.teamviewer.com/t5/Knowledge-Base/How-to-install-TeamViewer-on-Linux-without-graphi...

Also reading here https://www.teamviewer.com/en/remote-access-headless-linux/ it states "After installing the TeamViewer package, just run teamviewer setup (as root) to configure it for headless use." - is it possible to configure this via configuration file ?

 

Any help apprecaited !

 

Thanks,

 

 

 

1 Reply
1 Reply
Posted by arabold
Henagon

Re: TeamViewer install on Ubuntu 18.04 - unable to connect

I have exactly the same problem and spent the better part of the day looking for a solution. Tried updating my grub config and anything else I could think of. Without success :(

@fitzgerm , did you find out a solution yourself in the meantime?