Posted by glawen

cannot run teamviewer on a CentOS 7 virtual machine

I have a CentOS 7 virtual machine with GNOME 3.22 installed, which I control via Putty from a Windows 10 machine.

I use X11 forwarding with Xming installed on windows, and it seems to work, I can (for example) run xclock. I installed the epel repository, got the latest teamviewer rpm package (teamviewer.x86_64.rpm) and installed teamviewer, it went all right. I then ran the teamviewer setup, it asked for my credentials, and I could add my Linux machine to my trusted devices. My Linux machine appears in the list.

I then tried to run teamviewer using the simple 'teamviewer' command, and it works, but only up to a point : a small teamviewer window opens, but in it, there is only an error which says : 'Invalid X11 configuration found (DISPLAY:localhost:11.0), TeamViewer can not start'.

I've tried running it under my normal user account and also under the root account, but it did not change anything.

What can I do ?

Thanks in advance


1 Reply
1 Reply
Posted by vwwffsax

Re: cannot run teamviewer on a CentOS 7 virtual machine

I have the same problem and suffering from this until a month ago. so I tried to reinstall the graphics libraries such as GNOME Desktop and Xorg but It wouldn't be changed. my DISPLAY variable is manually set to 'localhost:0.0' by command line 'export DISPLAY=localhost:0.0'. In fact, that small windows (which is announced by the poster) have not shown until I had typed this command.

NVIDIA driver and CUDA Toolkit have installed on my computer for the scientific calculations. Nouveau was blacklisted for the installation of NVIDIA.

Does somebody know how we get over these issues?