Announcements

TeamViewer IoT is hiring! Check out the open positions here!

Highlighted
Posted by TeamViewer Staff
TeamViewer Staff

"Verification of TeamViewer failed!" on Linux

If TeamViewer gives you the error message "Verification of your TeamViewer version failed!"

 

You could fixed with the following steps:

Please remove any prior versions of TeamViewer before installing the latest version. Below are the steps to complete:

 

1) Either uninstall TeamViewer it or make sure TeamViewer is not running

You may use this command to stop TeamViewer (requires root):

daemon teamviewer stop

 

2) Use this command if TeamViewer is installed:

 

rm -rf /home/*/.local/share/teamviewer*

 

3) When using the TeamViewer tar.gz, the simplest way is to just delete it and download/upack it again. If you want to keep your settings, change into the folder you unpacked TeamViewer into and use the command:

 

4) Now all associated files and folders will be remove. All steps are help for working for the installed or the only start Version of TeamViewer.

 

5) If you stopped TeamViewer,  restart it with the command:

 

teamviewer daemon start

 

Else, it is time to download and install TeamViewer from our website.

 

https://www.teamviewer.com/en/download/linux.aspx

1 Reply
Posted by cvcorv8
Photon

Re: "Verification of TeamViewer failed!" on Linux

Good afternoon,

Unfortunately this does not help me above. Is it possible that you can support via Quick Look what's going on.