Highlighted
Posted by aaront
Photon

Limited to Using Legacy Version 12

Due to hardware limitations, I am unable to upgrade my OS beyond Mac 10.8.5. Just this week, TeamViewer announced in order to continue as a free user, it will become necessary to use TeamViewer 14. If I were to become a purchased license holder, would I be able to continue to continue using Version 12?

1 Reply
1 Reply
Posted by Moderator Moderator
Moderator

Re: Limited to Using Legacy Version 12

Hi @aaront 

Thank you for your post. 

If you buy a license, you have the possibility to use an older version. But we recommend using the latest version anyways :) 

I hope this could help. If you have any further questions regarding our licensing, my colleagues in the several Sales teams are really happy to assist. 

Have a great day and all the best,
Natascha