Posted by Beirtech
Photon

Major previous versions not compatible with respective OS?

I am unable to join my windows box , it says the version needs to be updated. How do I get the previous 12 version that will allow the previous debian 12 version to connect?

When installing TeamViewer 12 from previous versions the linux and windows are not compatible with each other. (https://www.teamviewer.com/en/download/previous-versions/)

I have TeamViewer Host installed on my windows box.
I have TeamViewer deb 32-Bit / 64-Bit Multiarch installed on my debian laptop.