Announcements

Shape the future of the TeamViewer product with our Product Team. Click here to join!

Posted by Contour
Henagon

No connection to TeamViewer Server since new license

Hi,

I've been using Teamviewer 13 premium on a couple of servers (Windows 2012) and one notebook (Windows 10) The original license expired end of april 2018. 
I've been able to use teamviewer a couple of weeks after the initial expiration. I've registred the product only with a serial-number. 
Since we needed a new license, i've ordered a new one, and linked the new license to my e-mail address. 

However, my already installed Teamviewer keeps saying "No connection, check your internet connection" on the server and notebook which previously have been using Teamviewer 13 with the old license. 

This error has nothing to do with my internet connection, I even tried a "Pass all" rule on both my software, and hardware firewall.

I've tried to uninstall, and reinstall Teamviewer 13, but still the same error.

I've tried "Activate license" and Legay device Activation, which states: The license has already been activated on this device. 

I've tried a uninstall, complete registry cleanup, new install, but still the same error, no connection, blablabla. 

When I install Teamviewer 13 on a new server (which hasnt used Teamviewer previously) it's working flawlessly. But the problem is I need Teamviewer on my other server, and on my notebook. 

It looks like Teamviewer is somewhere blocking my mac-address  (or hostname?) and just need a simple "clear". I can't log a support ticket with teamviewer however, the do no recognize my e-mail address. (I can use this e-mail adres however, to login to teamviewer, and on the portal, I can see that the premium license has been activated)

Anyone got any suggestions ?