Announcements

Remote Control for all devices running Android 7+ is here!

(Incl. Google Pixel series, Xiaomi smartphones, Oppo devices, and many more)


Learn more

Highlighted
Posted by
Henagon

Version Incompatibility?

I needed to connect with another TeamViewer user and we couldn't make the connection from either site. I have version 11 and she has version 12.

Are these two versions truly incompatible with each other? We've connected in the past and I don't think either of us has updated out TeamViewer version since then.

If they're compatible, what could have gone wrong today?