Highlighted
Posted by MorsePacific
Henagon

Automating deployment on MacOS

I've spent far too long on this, so I'm reaching out for help. I have to say, the documentation provided for TeamViewer is some of the worst I've come across. Yesterday I was trying to put together a Group Policy-based install for Windows and spent hours following a frustrating process of reading and trying old documents which were still in the wild, only to accidentally find one that said "Oh hey now there's a new process that's totally different!"

Even then there was still a lot of trial and error to actually make it work.

And so we find ourselves at the Mac side.

I've created my custom Host and installed it, and am running the following command:

sudo /Applications/TeamViewerHost.app/Contents/Helpers/TeamViewer_Assignment assign YES -api-token 123456-ReallyLongStringGoesHere -group GroupName -grant-easy-access

This is, as best I can tell, the right string. (Oh yeah, found yet another article, published about a month before the 'current' one that looked current enough and had a totally different string which doesn't even work ... sweet)

I also tried it with "assign YES" in there.

However it does nothing. The Host still doesn't assign, doesn't add itself to the group, doesn't turn on Easy Access. This is the exact same string I'm using on the Windows side (and works), just formatted for Mac.

I've tried it with the host running, the host not running. The host installed by double-click, the host installed by terminal command. Whatever I try, it runs, it shows me no errors, and it does nothing.

I'm pretty much at my wits' end by this point. If anyone could point to where I'm going wrong I would greatly appreciate it!!

Also, why is it that I can create the Host file, even telling it in the setup 'Assign to these groups, blahblah' and none of that actually happens until I run a transform / assignment set of commands on it? What's the point in putting those options in if it just .. doesn't work? Again, if I'm missing something I'm all ears.

Apologies for the irritated tone of this post but I've spent two days with this so far and don't understand why this is not a whole lot simpler. Ignoring the already-deployed clients out in our estate that we can't just in-place upgrade, because TeamViewer doesn't work like that. Ugh.