Posted by bgeecaver
Henagon

Forcing IPv4 only

Is there a way to force TeamViewer to use only IPv4? Background: I am running version 14.1.3399 on 64-bit Fedora 30. When I try to connect from a remote machine (also 14.1.3399 on Fedora 30), I always get a "partner failed to connect to router". The machine I am connecting to displays a not about "Incoming connection" but never does the connection. HOWEVER! If I turn off IPv4 on the partner computer, then it works. The log file on the partner computer shows that it is making a connection to various TeamViewer servers using IPv6. The computer where I initiate the connection does not have IPv6 available to it. I suspect the two systems are not connecting because they are using different IP versions. Hence my request - I want to force TeamViewer to use only IPv4. Leaving IPv6 completely disabled on the partner computer is not an option. There are some internal systems that I cannot reach by IPv4. Thanks - Bill Gee
Bill Gee
1 Reply
1 Reply
Posted by bgeecaver
Henagon

Re: Forcing IPv4 only

Update - Since no one seems to have any answer to my question.... There is a typo in my original message. What I want to disable in Teamviewer is IPv6. I have been installing Teamviewer from the official repository. It seems that is a rather old version! Someone needs to get an update into it. Today I went to the Teamviewer web site and directly downloaded version 14.4.2669. After a few failures, it seems now to be working. I will test it more over the next few days to make sure it still connects. I suspect the failures were unsynced machine passwords. At the moment my testing is within my own local network. Both the called and calling machines are on the same subnet. The acid test will be to connect from a remote site. I might have to make a trip to Walmart or something to use their free wifi.
Bill Gee