Posted by TMCcomputer
Photon

Problem with 14.3.4730 Parameter -B (PasswordB64)

Hi, 

after updated to 14.3.4730 our batch files doesn't work with -B (PasswordB64). 

Every Time "Passwort invalid" is shown. 

Copy & Paste the Passwort works...

Is this a Bug oder is the a Change with Paramenter -B ? 

Thanks  

 

7 Replies
Posted by Community Manager
Community Manager

Re: Problem with 14.3.4730 Parameter -B (PasswordB64)

Hi @TMCcomputer 

Thanks for your post and welcome to our Community.

Indeed - there was a change in the latest release. See Windows v14.3.4730 (Full) - Change Log 

"Fixed a bug that prevented the successful connection when using the--PasswordB64 parameter as input for the TeamViewer.exe file."

Hope this info puts some light onto it. 

Thanks and best, Esther

Highlighted
Posted by TMCcomputer
Photon

Re: Problem with 14.3.4730 Parameter -B (PasswordB64)

Hi, 

thanks, 

i have read this too. But what is it mean ? befor this update we had no problems...  

Where can i download the pervious Version of 14 ? 

Thanks 

 

4 Replies
Posted by wright_is
Digon

Re: Problem with 14.3.4730 Parameter -B (PasswordB64)

We didn't have any problems before the update. Since the update, all entries in out TeamViewer Manager come up with incorrect password.

If we copy the password from our records, it is still rejected. If we create a session manually - manually enter the username and password, we can connect.

2 users are still on 14.1 and they can still connect to all remote computers, 2 users were automatically upgraded to 14.3.4730 and neither of them can connect to any remote computer.

I just tried updating the TeamViewer Host software on one of the remote computers, but I still can't connect over the TeamViewer Manager.

Edit: Just double checked the logs, TeamViewer Manager is starting a TeamViewer session with the -B parameter, so it is related.

Posted by Community Manager
Community Manager

Re: Problem with 14.3.4730 Parameter -B (PasswordB64)

Hi again,

just checked with our support and they recommend to:

1. check whether the Base 64 encryption is working correctly

2. raise a ticket with our support to let them have a look at this case.

Thanks and I hope it is working again quickly.

Best, Esther

 

Posted by wright_is
Digon

Re: Problem with 14.3.4730 Parameter -B (PasswordB64)

Still waiting for feedback from TeamViewer. I registered a ticket on Tuesday as I posted in this thread, but I have only had the automated reply that is was received so far.

Posted by wright_is
Digon

Re: Problem with 14.3.4730 Parameter -B (PasswordB64)

Just run a quick PowerShell test:

.\TeamViewer.exe -i <machineID> -B [Convert]::ToBase64String('<password>')

And that doesn't work. I then tried:

.\TeamViewer.exe -i <machineID> -p '<password>'

That worked fine, no problems at all.

It certainly looks like the -B parameter is currently broken. Is there any way to roll back to the previous build until this issue is resolved?

Posted by wright_is
Digon

Re: Problem with 14.3.4730 Parameter -B (PasswordB64)

I just got a reply from TeamViewer support, that the Manager is no longer supported and we should swap to the web based management interface - something we can't do for legal reasons...

But the problem is specifically with the -B parameter, which is not currently working as advertised.

Edit: And in this thread, Julia from TeamViewer says that the developers have acknowledged a bug in the current version and provides a download link to the previous version.