Posted by IDPBBrisa
Photon

Not ready. Please check your connection (Teamviewer not connecting to master server ErrorCode=10

Could someone help me, i have recently switched my router, i used teamviewer for a few days it was all ok, 3 days ago it just stopped working suddenly, i checked the log file and it says Teamviewer couldn't connect to master server, with ErrorCode=10, also my mobile can't connect to teamviewer,  unless i switch to mobile connection instead of my WiFi.

I don't have firewall enabled, i also tried portforwarding 80 TCP&UDP, 5938 TCP&UDP, i tried rebooting my system, rebooting router, reinstalled teamviewer, no solution.

here is the log:

Spoiler
2017/02/12 08:45:44.923 2580 3596 S0 Activating Router carrier
2017/02/12 08:45:45.417 2580 3600 S0 CKeepAliveClientClient::HandlePing(): success
2017/02/12 08:45:45.417 2580 3600 S0 Non-Commercial use
2017/02/12 08:45:45.417 2580 3600 S0 Resource-Language: en
2017/02/12 08:45:45.417 2580 3600 S0 Activating Router carrier
2017/02/12 08:45:45.417 2580 3600 S0 CProcessCommandHandlerMasterConnect[444]::CreateMasterConnect(): master7.teamviewer.com:5938, Connection 444, proxy=''
2017/02/12 08:45:50.418 2580 3600 S0 CTcpConnectionBase[444]::HandleConnectTimeout(). Connect timed out to master7.teamviewer.com:5938
2017/02/12 08:45:50.418 2580 3596 S0! CProcessCommandHandlerMasterConnect[444]::HandleMasterConnect(): MasterConnect to 0.0.0.0 failed
2017/02/12 08:45:50.418 2580 3596 S0!!!Connect to Master master7.teamviewer.com / 178.77.120.102 failed!
2017/02/12 08:45:50.418 2580 3596 S0!! CMasterConnectorAsio::HandleMasterResponseLogin(): MasterConnect failed. ErrorCode=10
16 Replies
Posted by Neera-Singh
Henagon

Re: Not ready. Please check your connection (Teamviewer not connecting to master server ErrorCode=10

Hi All,

I had same error when I updated my Teamviewer as 12, I started to get this error. I had tried everything which all are suggested on web regarding this error , everything means everything. Below are my efforts which I think help some one.

What I had tried:

  1. Disable Windows Firewall
  2. Disable Antivirus Firewall (If you have any)
  3. Check Internet connection (some time users forget to start..)
  4. Run > Services.msc > Teamviewer 12 > Stop/Start
  5. Uninstall and Install Fresh Teamviewer 12
  6. After Uninstalling run a PC Cleaner tool to delete any leftover files
  7. Install again Old version of Teamviewer and removed Teamviewer 12
  8. Uninstall Antivirus Software from PC
  9. Start Teamviewer 12/Other as Administrator mode
  10. Flush DNS Cache (Run > CMD > ipconfig /flushdns > Enter)
  11. Disable/Enable Network Adapter (Run > ncpa.cpl > Disable/Enable)
  12. Install Teamviewer on Mobile Device and Login
  13. Start Teamviewer in Compatibility Mode (Windows 7/8 etc...)

 

Stage of Success:

  1. Made yourself Angry... :smileylol:
  2. Uninstall all Local Area Network Drivers/WiFi Drivers
  3. Restart Computer
  4. Install Drivers again
  5. Restart Computer
  6. Start Teamviewer (any version)
  7. Now... all working again.. :smileyvery-happy: like nothing was happen
  8. Take a Break and go for Air....
-Neeraj Singh
Posted by Henrywong
Digon

Re: Not ready. Please check your connection (Teamviewer not connecting to master server ErrorCode=10

Dear Neera-Singh: Your all step I had go to,but teamview can't work also,they are show:"Please check your internet connection. Most likely you use a proxy server and you have to enter the proper information in the options dialog. ", since 8 April,always can't connect,I spent two days solve it,so tried!!!
Posted by heinzler
Photon

Re: Not ready. Please check your connection (Teamviewer not connecting to master server ErrorCode=10

Same problem here since 8 april. Using teamviewer 12. I don't think it is a computer problem since others seem to have the same issue. Some server problem?

Posted by DrSqueak
Photon

Re: Not ready. Please check your connection (Teamviewer not connecting to master server ErrorCode=10

I am having the exact same issue and I have contacted Team Viewer support.  They troubleshooting steps have not helped to resolve this issue at all. 

Hello

Thank you for your email.

Please follow these basic steps for troubleshooting.

1. Please shut down the software completely by shutting down the processes as well.
2. Flush your DNS or clear out anything that is related to TeamViewer.
3. Remove TeamViewer and install a fresh copy.

Please let us know if you need any further assistance.

We hope you have found Customer Support to be helpful.

Feel free to contact Customer Support if we can provide further details at 1 800 951 4573.

Best regards,

Scott Bushore
Customer Support Specialist

Posted by Doron
Digon

Re: Not ready. Please check your connection (Teamviewer not connecting to master server ErrorCode=10

Same problem here

tried everything, nothing works.

Really frustrating, any solution? 

Posted by hadikazemi
Photon

Re: Not ready. Please check your connection (Teamviewer not connecting to master server ErrorCode=10

sudo teamviewer daemon stop
sudo teamviewer daemon start 

Worked for me.

Posted by jake73_oulu
Photon

Re: Not ready. Please check your connection (Teamviewer not connecting to master server ErrorCode=10

Had the same issue on Win7 and Teamviewer 11. Funny thing was that one of five computers had connection to Teamviewer server, but the others didn't (they all worked out fine earlier).

So it seemed that it hadn't anything to do with firewall. But since I couldn't find any other reason, I added a rule to firewall that allows traffic to *.teamviewer.com on TCP/UDP Port 5938. And that did the trick, now there's connection on all five computers.

Posted by DHS
Photon

Re: Not ready. Please check your connection (Teamviewer not connecting to master server ErrorCode=10

Had the same problem on Win7 with TeamViewer 12.

Tried to Exit Teamviewer and launch it again several times w/o any result. So I stopped it and...

...then I located the TeamViewer service in Services system window and tried to Stop it. Actually, it ended up with an error dialog saying "the service did not respond", but when I launched the TeamViewer application again, it requested administrator rights (which I confirmed) and connected to the server successfully then. So here are the steps:

  1. right-click on the TeamViewer icon in Windows Tray and select Exit Teamviewer
  2. in Start menu type "services" to locate the Services option, then click on it to open its window
  3. locate the TeamViewer service and click the "stop" button (or right-click on it and choose "Stop")
  4. in Start menu type TeamViewer and lauch TeamViewer again - should work now
Posted by asciigod
Henagon

Re: Not ready. Please check your connection (Teamviewer not connecting to master server ErrorCode=10

@DHSthanks so much, this solution worked for me.

Posted by garch
Electron

Re: Not ready. Please check your connection (Teamviewer not connecting to master server ErrorCode=10

thanks @DHS this worked for me too!

Posted by sallyc
Henagon

Re: Not ready. Please check your connection (Teamviewer not connecting to master server ErrorCode=10

I still can't solve this problem. I try all but still can't. Please help.

Posted by yoosuft1988
Photon

Re: Not ready. Please check your connection (Teamviewer not connecting to master server ErrorCode=10

Hi...alll

 

please check your compter..which have any remote access application..it can be the problm..please close all your application which is running on your background..

 

Posted by saracenrush
Henagon

Re: Not ready. Please check your connection (Teamviewer not connecting to master server ErrorCode=10


@DHSwrote:

Had the same problem on Win7 with TeamViewer 12.

Tried to Exit Teamviewer and launch it again several times w/o any result. So I stopped it and...

...then I located the TeamViewer service in Services system window and tried to Stop it. Actually, it ended up with an error dialog saying "the service did not respond", but when I launched the TeamViewer application again, it requested administrator rights (which I confirmed) and connected to the server successfully then. So here are the steps:

  1. right-click on the TeamViewer icon in Windows Tray and select Exit Teamviewer
  2. in Start menu type "services" to locate the Services option, then click on it to open its window
  3. locate the TeamViewer service and click the "stop" button (or right-click on it and choose "Stop")
  4. in Start menu type TeamViewer and lauch TeamViewer again - should work now

Tried a bunch of stuff. Haven't been able to use Teamviewer for like a month. Multiple reinstalls did nothing.

Bizarrely, this worked. Thank you!!!!!!!!!!!!

Posted by osita
Photon

Re: Not ready. Please check your connection (Teamviewer not connecting to master server ErrorCode=10

it really worked for me i appreciate, thanks
Posted by Soper
Electron

Re: Not ready. Please check your connection (Teamviewer not connecting to master server ErrorCode=10


@yoosuft1988 wrote:

Hi...alll

 

please check your compter..which have any remote access application..it can be the problm..please close all your application which is running on your background..

 


This worked for me, thanks a lot. In my case, I had a program called "Parsec" running. After closing it, Teamviewer was able to connect.

Posted by DocDisco81
Electron

Re: Not ready. Please check your connection (Teamviewer not connecting to master server ErrorCode=10

Hi had the very same issue today with Teamviewer 14 under Windows 10 version 1803 and I solved in the very same way.


@DHS wrote:

Had the same problem on Win7 with TeamViewer 12.

 

  1. right-click on the TeamViewer icon in Windows Tray and select Exit Teamviewer
  2. in Start menu type "services" to locate the Services option, then click on it to open its window
  3. locate the TeamViewer service and click the "stop" button (or right-click on it and choose "Stop")
  4. in Start menu type TeamViewer and lauch TeamViewer again - should work now