Announcements

Would you like to co-innovate with us? If so, we’d like to invite you to become product development partners with us. Read more about it in our announcement Launch of the TeamViewer User Focus Program

Posted by MatthewV
Henagon

TeamViewer 13.2 importing TeamViewer ID instead of HostName into console

Hello all,

I have a wonderful deployment script I put together that removes previous versions of TeamViewer, installs 13.2, and then moves the device to the correct group in my TeamViewer online console with the correct policy while also importing the local password.

Well, I thought everything was working. I am still in testing before I rollout to 3,500+ workstations. Now, instead of seeing the HostName in my TeamViewer web console, I see the 9 digit TeamViewer ID.

Any ideas why? We pay for support but thought I'd post here in the community for others as well.

Here are my install parameters, which have not changed during testing:

/QN /NORESTART IMPORTREGFILE=1 CUSTOMCONFIGID=MYCONFIG APITOKEN=MYTOKENb ASSIGNMENTOPTIONS="--group MYGROUP"
4 Replies
1 Accepted Solution

Accepted Solutions
Posted by Senior Moderator Senior Moderator
Senior Moderator
Solution

Re: TeamViewer 13.2 importing TeamViewer ID instead of HostName into console

Hi @MatthewV

Thanks for posting this!.

You would need to post an "alias" as an assignment option.
eg.

ASSIGNMENTOPTIONS="--alias %COMPUTERNAME%"

 

So your example would read

/QN /NORESTART IMPORTREGFILE=1 CUSTOMCONFIGID=MYCONFIG APITOKEN=MYTOKENb ASSIGNMENTOPTIONS="--group MYGROUP --alias %COMPUTERNAME%"

 

I hope this helps!

-Scotty

Senior Moderator
Did my reply answer your question? Why not accept it as a solution to help others?
4 Replies
Posted by Senior Moderator Senior Moderator
Senior Moderator
Solution

Re: TeamViewer 13.2 importing TeamViewer ID instead of HostName into console

Hi @MatthewV

Thanks for posting this!.

You would need to post an "alias" as an assignment option.
eg.

ASSIGNMENTOPTIONS="--alias %COMPUTERNAME%"

 

So your example would read

/QN /NORESTART IMPORTREGFILE=1 CUSTOMCONFIGID=MYCONFIG APITOKEN=MYTOKENb ASSIGNMENTOPTIONS="--group MYGROUP --alias %COMPUTERNAME%"

 

I hope this helps!

-Scotty

Senior Moderator
Did my reply answer your question? Why not accept it as a solution to help others?
Posted by MatthewV
Henagon

Re: TeamViewer 13.2 importing TeamViewer ID instead of HostName into console

Edit:

There were too many quotes:
NOT Working:

/QN /NORESTART IMPORTREGFILE=1 CUSTOMCONFIGID=MYCONFIG APITOKEN=MYTOKENb ASSIGNMENTOPTIONS="--group MYGROUP" "--alias %COMPUTERNAME%"

Working:

/QN /NORESTART IMPORTREGFILE=1 CUSTOMCONFIGID=MYCONFIG APITOKEN=MYTOKENb ASSIGNMENTOPTIONS="--group MYGROUP --alias %COMPUTERNAME%"
Posted by Senior Moderator Senior Moderator
Senior Moderator

Re: TeamViewer 13.2 importing TeamViewer ID instead of HostName into console

Sorry about that @MatthewV

You are absolutely right, serves me right for copy-pasting.

I have edited my response as well to correct the problem.

-Scotty

Senior Moderator
Did my reply answer your question? Why not accept it as a solution to help others?
Posted by itsupporta
Henagon

Re: TeamViewer 13.2 importing TeamViewer ID instead of HostName into console

This was working in v13.2 but in V14 i have issues with mdt deployment.

For example:  my default mdt deploy starts with a pre defined template name: pc-

During deployment i set the pc name as :pc-test
During install teamviewer agent has the correct alias set in the config menu (pc-test) but the name reported in thet management tool is pc-

Totally weird.

Any ideas?

It looks like %computername% is not used all the time