Announcements

Become a product development partner for TeamViewer. Read more about it in our Announcement.

Posted by Mrorpheus
Digon

Very High CPU suddenly on Teamviewer 14

Hi,

I noticed my i7 (6600k) started fanning up and looking I saw Teamviewer using upto and over 50% and some other process I think related to it which put my processor at 100% the only way to stop this was to kill teamviewer program. I recently updated and I thought that had solved it but it came back again with very high cpu usage (basically sending my graphics workstation to 100%!).

Please help, I can't access my remote machine and when I do it's at 100% also!

21 Replies
21 Replies
Posted by cntry2001
Digon

Re: Very High CPU suddenly on Teamviewer 14

TV support seem to just be hiding from this issue.

Posted by Mrorpheus
Digon

Re: Very High CPU suddenly on Teamviewer 14

Yeah I just had it running, and had left it on as it seemed ok, then came back to my computer and TV was using close to 85% on a i76600k totally crazy.

Posted by mil6seven6
Digon

Re: Very High CPU suddenly on Teamviewer 14

I have 20 Dell business grade machines running Windows 10 pro ranging from desktops and laptops and micro PCs all of which are showing the exact same symptoms for approximately the last two weeks I have opened a support ticket with TeamViewer with still no resolution
Posted by Mrorpheus
Digon

Re: Very High CPU suddenly on Teamviewer 14

I wonder if this is a Windows 10 update issue, but why does TV update and get slower and more unreliable.

Posted by DaveR_uk
Photon

Re: Very High CPU suddenly on Teamviewer 14

Holy moly.

Not used my flight sim PC for a little while and it seemed odd to be running hotter than usual.Just spent the morning removing light dust, then on the back of a small issue checked TaskMgr to see TV14 doing some serious hogging. Killed it and my i7 8700K is now back to single digits when not running my sim.

Posted by Peterc34
Digon

Re: Very High CPU suddenly on Teamviewer 14

Same on my i7-7700 Acer laptop (less than 2 years old). Upgraded to latest TV version. Recently, I returned home to find my laptop HOT, with screaming fans but NOTHING going on (I use TV to remotely use my home laptop occasionally from work). CPU usage was 80%+.

When I use Task Manager to kill TV, CPU usage drops to about 6% and the fans stop. This CPU hogging is now a daily occurence, even on days when I have NOT used TV to remotely access this computer. TV used to sit idle and not make the fans run AT ALL. Now, even idling, the fans are going non-stop. The next-biggest CPU user is at 0.5% (one half of one percent).

This morning, TV is booted and ready, but no connections were made. TV is currently hogging up 50% of the CPU and the fans are spinning at medium speed -- while doing absolutely NOTHING but sitting there waiting.

However, on my desktop system at work, TV is idling at ~0% CPU, which is ideal. Update: I connected to my home system from work. CPU usage for TV was 96%!!! (with multiple entries in Task Manager --- could THIS be the bug?). Rebooted it remotely. Now it's showing TV at a respectable 16-18% while I'm connected remotely.

TV is now unusable to leave idling at home unwatched, unless I want to risk sending my laptop to an early grave.

THIS IS A BUG!!!! THIS IS A BUG!!!! THIS IS A BUG!!!!

Posted by OSGuilherme
Henagon

Re: Very High CPU suddenly on Teamviewer 14

Now it's even worse! Every time I turn on my computer I go to the clockwise icon in Windows and close TeamViewer. After a few days it does not start any more along with Windows. But I notice that the fan is turned on and the temperature is high. From there I went to look at the task manager and there is TeamViewer hidden, consuming 7% -50% of my CPU. This happened several days.

Posted by mil6seven6
Digon

Re: Very High CPU suddenly on Teamviewer 14

Downgrading the full/host version to v14.1 and turning off auto-updates has resolved the high cpu issue for us.

Have to mention we are running a temporary 4G internet connection on our network using a Nighthawk M2 modem router which has no firewall port controls. We suspect our temp router is not allowing TW communications via the normal TW 5938 port and so has to reply on using port 443 which should also work but with v14.2 it doesnt.

Regardless, something is not right or has changed with v14.2 that causes the high cpu usage, so we will wait for a new build or v14.3 before updating.

Posted by Mrorpheus
Digon

Re: Very High CPU suddenly on Teamviewer 14

Thanks appreciate that.

I'm using this the personal free edition so I don't need it on all the time, I just close my TV down, but if a fix doesn't come down, I'll install the older version.

It's strange I'm running TV now and it's at 0.1% - while connected, I think if I leave it on at some random point it will go back to using almost 100% resources.

Posted by Peterc34
Digon

Re: Very High CPU suddenly on Teamviewer 14

Update on my i7-7700 Acer Helios laptop: I downgraded to TV 13.2  (couldn't find 14.1 anywhere) and now CPU usage is ZERO when not connected, all day long! Happy boy! It's also a mere 5% of less when I connect to it from my office machine. Very reasonable.

No need to dump TV for something that 'works properly', but now TV will nag me to "upgrade "to the latest version" until the end of time. Small price to pay for proper software behavior...

TeamViewer Tech Support: This is completely confirmed now! BUG WITH v14! Please fix it. If you want me to run some tests on MY machine for you, contact me and I'll help the best I can.

Posted by infodim
Henagon

Re: Very High CPU suddenly on Teamviewer 14

Same problem for me: CPU usage 100%, 95% - TV

Posted by Kevin_Burana
Photon

Re: Very High CPU suddenly on Teamviewer 14

Hey All, 

I am running a i5-8400 and CPU usage is at 100%. TV .exe is the culprit and I suspect that this is due to the recent TV 14 update? Any thoughts as to what's going here. I definitely did not have the issue of high CPU usage since this update. 

Posted by andreicrf
Henagon

Re: Very High CPU suddenly on Teamviewer 14

temporary solution that worked for me:
- downgrade to version 14.1 and disable automatic updates in advanced tab in settings

Posted by Peterc34
Digon

Re: Very High CPU suddenly on Teamviewer 14

Did you look in the Task Manager to see who the CPU hog was? Click on processes tab, then click the CPU column ntil you see the down-arrow (sorts from higest to lowest in CPU usage). You'll see TV there at the top, hogging it ALL, endlessly looping broken code, while burning up your computer and fans.

Hey TeamViewer Dev team: Ya gonna FIX this anytime soon? Plenty of us see this issue, so you ought to be able to reproduce it in-house.

Posted by Peterc34
Digon

Re: Very High CPU suddenly on Teamviewer 14

Where did you FIND the TV 14.1 version? I wasn'ty able to locate it online and went with 13.x instead. I'll try v14.1 if I can get ahold of it. Link?

Posted by cntry2001
Digon

Re: Very High CPU suddenly on Teamviewer 14

I had a support ticket in and they confirmed its a known issue with the high cpu usage. Still pretty **bleep** noone from support says anything about it on the forumns.

Posted by Sarlaac
Electron

Re: Very High CPU suddenly on Teamviewer 14

This issue has no solution and as a result I’ve decided to move away from teamviewer permanently. Good luck boys and girls. I’ve had enough.
Posted by Coypu76
Henagon

Re: Very High CPU suddenly on Teamviewer 14

Same issue here on my field laptop. Since the update to Teamviewer14 I have noticed high CPU utilization. Also the connection and authentication handshake has gotten much (several times) slower than on version 13. The high utilization makes my laptop useless for some time after starting. The handshake slowness impedes my ability to use Teamviewer to support my client machines. If this isn't fixed I will need to consider ending my corporate subscription and finding a different solution.
Posted by RupertB
Electron

Re: Very High CPU suddenly on Teamviewer 14

Same here with my 1 year old XPS 13, i7-8550U..

Today I killed it 4 times at 100% cpu and the 5th time I started it, it is running normal ...

Hoping for a bugfix soon! I need it for my work and I cannot force my customers to use a different software :-(

Posted by Peterc34
Digon

Re: Very High CPU suddenly on Teamviewer 14

HAPPY UPDATE: I decided to see if v14.3 works better than 14.2 regarding CPU usage. I figured I could always just drop back down to 13.x again if needed (which fixed the high CPU usage issue).

Version14.3 works great on my i7-7700HQ Acer Helios 300 laptop. Instead of 50-95% CPU usage, it's hovering around 0% (zero percent), even when connected and working on a remote system. I decided to leave it running for the last 6 hours. Came back and it's still at 0% CPU usage. Problem seems to be fixed now. Very happy.

Posted by Moderator Moderator
Moderator

Re: Very High CPU suddenly on Teamviewer 14

Hi @Peterc34 ,

Thank you very much for your feedback.
We are glad to hear that.
Please do not hesitate to post if there is any other questions or issues.

Have a wonderful day!
Best, Yuri