teamviewer.com link icon
or
Ask The Community

Initializing display or screen cannot be captured

I have been using TeamViewer for years. I have a desktop and laptop for around 1year that have worked flawlessly. Now 80% of the saved connections I try logging into it hangs at the screen “cannot be captured at the moment” or “Initializing display parameters). Keep in mind this is not just for a few PCs. It happens to me ALL DAY LONG for the last month. I called support and was on hold a few times for an hour and was disconnected. Getting frustrated enough to switch software if I can’t get this resolved. I can have the user access my TeamViewer and switch screens and it works perfectly. Thanks

Tagged:

Comments

  • JeanK
    JeanK Posts: 3,619 Moderator

    Hello @Steelenetworks

    Thank you for your message and welcome to the TeamViewer Community! ?

    I recommend you to restart the TeamViewer service on your device.

    We explain how to proceed in this post right here: Restart TeamViewer service 

    I hope this could help. ?

    Best regards

    Jean

    French Community Moderator
  • Thanks for your fast response. It didn’t make any difference at all. I tried on my laptop and my desktop. If the monitor connected to the remote pc is much smaller than mine, I do not seem to have an issue. Like a 15-17" server monitor. When logging into user PCs that have 22-27" seems to be when I have the issue. This never happened in 3 years with a version under 15. Seems hard to believe its only me having the issue unless something has been changed in my settings. I have many PCs added to my account and have always used the default settings. I haven’t changed one thing. Thanks

     

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!