teamviewer.com link icon
or
Ask The Community
Update now to the most recent TeamViewer version 15.18. See Change Logs.

[Linux] v15.10.5 (Full) - Change Log

KarlaR
KarlaR Posts: 160 [Former Staff]

Operating system: Linux

Version: 15.10.5

Release date: 2020-09-22

 

Bug fixesChange_Log_bug_fixes.png

 

  • Fixed a bug in the main window, which led to the display of a free license banner when TeamViewer is used with a commercial license.
 
Spanish Community Moderator
Tagged:

Comments

  • Truckeeer
    Truckeeer Posts: 10 ✭✭

    After update from 15.9.5 to 15.10.5  on Ubuntu 20.04 connection not possible from my windows PC.

    TV tries to connect, but nothing happens. When you login local and the login screen is gone, TV can connect.

    First it looked like the typical "wayland problem", but it isn´t.

    I´m now back on 15.9.5, and everything´s fine.

    Looks like you changed more than just a banner bug problem...

  • Same problem here. Just updated TeamViewer to 15.10.5 on servers and client, and now we can only connect if someone is already logged in on the server. If I fire up NX, connect and then log in, TeamViewer starts working until I logout.

    I see the following errors in the log:

    2020/09/25 16:21:00.656 1537 **Please do not post TeamViewer IDs**25472 S CSendCommandToMaster::SendBCommandToMaster: CC=3 CT=91
    2020/09/25 16:21:00.656 1537 **Please do not post TeamViewer IDs**25472 S UDPv4: [44]: create udp connection was not successful: UdpHolePuncher shutting down: (*)
    2020/09/25 16:21:00.657 1537 **Please do not post TeamViewer IDs**25472 S UDPv6: [44]: create udp connection was not successful: UdpHolePuncher shutting down: (*)

  • KarlaR
    KarlaR Posts: 160 [Former Staff]

    Hi @nusol-sc  and @Truckeeer 

    Thanks for your message and welcome to the community!?

    May I ask if the remote side has been updated as well to the new version? or it happened on all your connections? You could try to update again both devices to the latest version and if the problem persists please directly ? call our support team, they will be happy to help you. 

    I hope this helps  ?

    I wish you a very nice day,

    Karla

    Spanish Community Moderator
  • Truckeeer
    Truckeeer Posts: 10 ✭✭

    Hi Karla,

    Ubuntu is the server.

    It doesn´t matter which windows version you use as client (I tried 15.9.4 and 15.10.5).

    I can connect to Linux version 15.9.5 with both windows versions, but not to Linux version 15.10.5.

    The bug is definitely in Linux version 15.10.5

    Best regards

  • Ph7s
    Ph7s Posts: 4

    Do we have an update on when this will be patched?

    Does TeamViewer have the old version still available?

  • criadmin
    criadmin Posts: 7 ✭✭

    This problem happens in 18.04.5 as well.

    I have a Corporate License and I cannot even get these guys to respond.  It was assigned 1.5 days ago and still waiting.  I tried opening a bunch of new tickets referring to my first ticket, they ignored and deleted those.  I keep replying to my open ticket, no response.  To get someone on the phone takes so long, somethings else always comes up in the mean time.

    I tried **Third Party Product** (I am dyslexic, might have to reverse those two words) and it works fine, no issues.  I would be happy with a refund for the lack of service and we go our own way.

  • WillemPro
    WillemPro Posts: 2 ✭✭

    Same here on 18.04. Where is the previous version available?

  • criadmin
    criadmin Posts: 7 ✭✭

    Try apt-get install teamviewer=15.9.5

    If we wait for them, it might take them a week to respond, they are quick to protect their forums from competitor information though!

  • lello2
    lello2 Posts: 2

    fixed for me on a debian server rolling back to 15.9.5

    although surprisingly 15.10.5 works fine on an almost identical server

  • agreed their support is now a joke. 3 days ago i reported that again the marketing popup in the new version breaks connections randomly - 2 phone calls where they have lied and said they'd escalate but all they did was remove my post from here...
    i lost 5 computers and had to manually go and renstall - you cannot use SSH (or VNC or RDP) or it will lock you out, you have to be sitting infront of the screen.

    for windows if you are lucky when you close the marketing popup it will let you connect but with ubuntu you're scrwd as the popup never appears it just breaks the connection instead.
    the logs come back ok, the teamviewer servers think you have connected so will block you if you keep trying but you will never connect until you manually go and reinstall to actually get a new ID, until then those previous ID are dead even though they show on your lists as ready to connect. there is no pattern it just randomly breaks installs.
    (my 16s that were upgraded to 18 are far more stable than any 18 clean install)

    hate to say it guys but Teamviewer days are over, it's just not stable any more, there's zero support and all they do is push adverts to paid users....use  **Third Party Product**, as this is my 3rd time with this happeneing caused by their marketing popups it's their final chance before i use the UK/EU "fit for purpose" law to obtain a refund and move.

    btw people without licenses get better support now than people spending 1000s on this junk.

  • the marketing popups break the connection - if you can manually click on them it'll unlock you but on ubuntu you can't so you have to reinstall...but this won't work over ssh/rdp or vnc it MUST by done physically infront of the screen.

    grwat system eh unwanted intrusive adverts for things i aready bought break the system.

  • You are a freakin godsend.  I was working fine a week or 2 ago with teamviewer using all version of linux Mint, Ubuntu, OpenSUSE, etc.  Pretty much have auto update on my remote linux admin boxes.  We are a paying customer too.  One day I could not log into half my linux boxes.  Just sat on connecting until I logged into  Windows box, remote consoled into the linux vm, logged in and then I could connect.  Can lock the linux box and still connect and login too.  Just at login screen.  Was asking questions on the distro forums and come to find out it was an update that caused my woes.  I use Teamviewer-host on my remote machines.  I reinstalled it to the specified version mentioned and now I work.  So, I marked the package to not update.  In case anyone wants to know and using aptitude, to mark the package to not update until you are ready or sure.

    sudo apt-mark hold <package name>

    packages are "teamviewer" for the full version and "teamviewer-host" for the host only version.  Do this after downgrading.  I did not have to do this to my master machine I use to connect from..which is also linux.  Since I do not remotely connect to this machine, I do not need to downgrade unless the update breaks me being able to remote from it.

     

    Thanks for the awesome find.

  • criadmin
    criadmin Posts: 7 ✭✭

    They bleeped you too, does the product start with an A?


    @TV_user2 wrote:

    ....use  **Third Party Product**, as this is my 3rd time with this happeneing caused by their marketing popups it's their final chance before i use the UK/EU "fit for purpose" law to obtain a refund and move...

  • criadmin
    criadmin Posts: 7 ✭✭

    @criadmin wrote:

    Try apt-get install teamviewer=15.9.5

    If we wait for them, it might take them a week to respond, they are quick to protect their forums from competitor information though!


    It might be difficult to find a download to the binary directly if you need out of band access, so this might help for your solution, self-hosted but I work at https://www.crinj.com if you want to verify anything:

    https://tinyurl.com/teamv15095

    @TV_user2

  • criadmin
    criadmin Posts: 7 ✭✭

    Great suggestions.

    They are battling Wayland "issues" if you want to call them that, however a COMPETITOR and open source VNC (<-- I wonder if they would bleep that one) have managed to work with Wayland.  There are some significant changes to X11 but they make it sound like they would have to build an screen utility for each desktop.  That is wrong information from them and just plain silly.

    I get it Linux is a real pain in the **bleep** with community driven A-D-D issues throughout the decades, but they supported it, so find a solution.  What did VNC do?  Wayland will require possibly a more primitive approach and as time goes on that integration will improve and performance will get better.  No one is gaming over this stuff, this is all work related!  Servers and possibly some users.

    We as paying customers want reliable!

    **Rant posted here because support tickets and calling are useless as least the moderator will read this but I suspect that's as far as it will go.

  • Both the server and client were updated to 15.10.5. I rolled back the version on all our servers to 15.9.5 and locked the version to prevent it from upgrading until the issue has been resolved. The client is still 15.10.5.

  • Thanks a bunch for the solution. New updates have come out since this started but the issue remains. We have around 50 machines with teamviewer and we've been upgrading them to Mint 20 (from 19.3) and Teamviewer stopped working in the same way as described here.

    We were trying to figure out why it worked fine in 19.3 and not 20 (it's just that we weren't using the latest version on 19.3).

    We're now using 15.9.5 on Mint 20 and all is well.

    We had already decided to not renew Teamviewer on the next term due to their poor support and the complaints from our staff getting the stupid ads. No surprise here though.

  • criadmin
    criadmin Posts: 7 ✭✭

    Exactly our position too.  We have a price that is 1/2 as much from a competitor too and their agent doesn't seem to have this issue.  Hopefully their support will not have the same snarky attitude either.


    @Altersoundwork wrote:

    Thanks a bunch for the solution. New updates have come out since this started but the issue remains. We have around 50 machines with teamviewer and we've been upgrading them to Mint 20 (from 19.3) and Teamviewer stopped working in the same way as described here.

    We were trying to figure out why it worked fine in 19.3 and not 20 (it's just that we weren't using the latest version on 19.3).

    We're now using 15.9.5 on Mint 20 and all is well.

    We had already decided to not renew Teamviewer on the next term due to their poor support and the complaints from our staff getting the stupid ads. No surprise here though.


     

  • Hi friends,

    I have the same problem with my headless Ubuntu 20.04: after update TV from 15.9.5 to 15.10.5 I'm not be able to login into my server.

    Downgrade to TV 15.9.5 -> everything is fine and login works.

    TV 15.11.6 have the same login problem.

    Any other known solutions ????

    THX and with best regards,

    Matthias

  • boyan7640
    boyan7640 Posts: 2 ✭✭

    The issue is valid for Fedora 32/33 as well (15.11.6 is latest at the moment which is also impacted). The workaround is the same as already explained - remove latest version and install last working one with following commands until fixed:

    wget https://dl.teamviewer.com/download/linux/version_15x/teamviewer_15.9.5.x86_64.rpm
    sudo dnf install teamviewer_15.9.5.x86_64.rpm
    sudo sed -i 's/enabled=1/enabled=0/g' /etc/yum.repos.d/teamviewer.repo
  • To fix on debian:

    Rollback:

    • apt-get install teamviewer-host=15.9.5

    Stop TV from upgrading untill proper fix is available:

    • apt-mark hold teamviewer-host
  • boyan7640
    boyan7640 Posts: 2 ✭✭

    I am not sure in which version it was fixed but it seems it works as expected with current version (teamviewer-15.15.5-0.x86_64).

Sign In or Register to comment.