teamviewer.com link icon
or
Ask The Community

Can't connect to Ubuntu 20.04 after reboot

Hi there,

I am having problems connecting to an Ubuntu 20.04 machine running TeamViewer 15.10.5. I am running the same version locally, but on Windows 10.

When the Ubuntu computer is started, I can see it appear in my Computers & Contacts list, but I cannot connect to it using either the IP address or its TeamViewer ID. It just shows "Connecting..." and nothing happens.

I have these TeamViewer options set:

- "Personal password (for unattended access)" is set up
- The "Grant easy access" box is checked
- "Access Control" is set to "Full Access"
- "Random password after each session" is set to "Keep current"
- "Incoming LAN connections" is set to "accept"
- The device is assigned to my account

...are there any relevant settings I'm forgetting?

If I physically go to the Ubuntu computer and login, I am then able to connect with TeamViewer from my PC. If I lock the Ubuntu screen, no problem, I can still login remotely. The problem only returns if I log out of Ubuntu (or reboot).

Another alternative I've found is to connect first using Xrdp + Windows Remote Desktop. This seems to wake something up on the Ubuntu machine. Then I can close the Xrdp connection and TeamViewer will now be able to connect successfully.

Interestingly, the computer seems to have two different TeamViewer IDs, depending on whether I login to Ubuntu in person or using Xrdp. I have tried both IDs trying to test the connection, both just hang until I first login as described.

If I check teamviewer info in the terminal I get:

TeamViewer 15.10.5 (DEB)

grep: /opt/teamviewer/config/global.conf: Permission denied
TeamViewer ID:  ***(nothing shows up here)***
Try restarting the TeamViewer daemon (e.g. teamviewer --daemon restart)

teamviewerd status ● teamviewerd.service - TeamViewer remote control daemon
Loaded: loaded (/etc/systemd/system/teamviewerd.service; enabled; vendor preset: enabled)
Active: active (running) since Wed 2020-09-30 14:34:55 EDT; 33min ago
Process: 3989 ExecStart=/opt/teamviewer/tv_bin/teamviewerd -d (code=exited, status=0/SUCCESS)
Main PID: 3991 (teamviewerd)
Tasks: 25 (limit: 115813)
Memory: 71.7M
CGroup: /system.slice/teamviewerd.service
└─3991 /opt/teamviewer/tv_bin/teamviewerd -d

Sep 30 14:34:55 christine systemd[1]: Starting TeamViewer remote control daemon...
Sep 30 14:34:55 christine systemd[1]: teamviewerd.service: Can't open PID file /run/teamviewerd.pid (yet?) after start: Operation not permitted
Sep 30 14:34:55 christine systemd[1]: Started TeamViewer remote control daemon.

 

My /etc/gdm3/custom.conf file has "WaylandEnable=false" uncommented.

Any suggestions would be much appreciated!

Comments

  • JustSumDad
    JustSumDad Posts: 3 ✭✭
    edited January 25

    I found this could be related to two things.

    One of my systems had a dash it its name and this one gave the problem so i changed its name from UB-20 to UB20 and the problem seemed fixed.


    Then on another system that was dual boot, I was having a problem with time shift due to windows using local time and Ubuntu using UTC-offset time. I ran this command:

    timedatectl set-local-rtc 1 --adjust-system-clock
    

    This system was working fine with Teamviewer and after I changed from UTC to local time read as above, then it knocked me off and started having this issue.


    Just two ideas for someone else to verify. Hope it helps.

  • JustSumDad
    JustSumDad Posts: 3 ✭✭

    I am now fairly certain of the problem.

    When Ubuntu boots it sets the time by UTC then applies an offset.

    This causes the system to read the clock, then the teamviewer service starts and reads the system time, then the clock adjusts via either the offset OR corrects via NTP (not certain on this but I can see the clock change a few seconds after boot)

    Since the teamviewer service read a different time than the system now shows, it wont allow any incoming connections.

    This command has now fully cured the issue on three different systems for me:

    timedatectl set-local-rtc 0 --adjust-system-clock
    


Sign In or Register to comment.