teamviewer.com link icon
or
Ask The Community

Have to allow each time with host app

I just installed the Teamviewer Host app on my Pixel 4 running Android 11.  Each time I connect to my phone from my PC, the phone pops up with attached warning, and I have to tap 'Start Now' before I can control the phone.  I have to tap 'Start Now' physically on my phone, which means I can only remote control my phone if I have it with me in my hand.  I want to be able to leave it out in the other room, which I believe is the point of the Host app?

Does anyone know how I can accomplish true unnattended access with the Host app?  I'm assuming there is some way to disable this warning, or 'auto-allow' it?  Thanks in advance!!!!

Edit:  Since I couldn't find any results googling for the exact phrase Start recording or casting with Host I thought I should add the text in here for indexing

warning that appears on phone and must tap 'Start now' before I can remote control my devicewarning that appears on phone and must tap 'Start now' before I can remote control my device

Tagged:

Comments

  • Bump!! Same problem here. Trying to log into covid grandma's tablet

  • smpl
    smpl Posts: 7 ✭✭

    Ok, I found the solution:

    https://support.google.com/android/thread/13791498?hl=en&msgid=62539685

    1. install ADB on your computer
    2. install Shizuku on your phone, open Shizuku, "view command," copy command, close Shizuku
    3. Install (and purchase) App Ops on phone
    4. Enable Developer options on your phone
    5. Allow USB debugging on your phone (in Developer options)
    6. Connect phone to computer via USB cable
    7. Open terminal window on computer in ABD folder, and type in the command that you copied from Shizuku
    8. Open App Ops, look for application you want to allow PROJECT_MEDIA for, and allow PROJECT_MEDIA
    9. Close App Ops. You're done.

    2020-10-29_22-20-47.jpg

    You don't have to purchase App Ops. Free version is enough.
    It works perfectly for me.

    Sławek

  • Xav0
    Xav0 Posts: 2

    Same problem here... "unattended" but asking for permission...

  • fostex909
    fostex909 Posts: 1 Newbie
    edited February 18

    Thank you smpl for this solution! This has worked for me on a Samsung Tab A.

    Under App Ops, the app I had to search for was "Host" since I had the Teamviewer Host app installed on my Tab A. Once I was in there I was able to see the PROJECT_MEDIA permission and allowed it.

    For anyone else doing this on a Samsung Tab A, I had to connect the ADB via Powershell from my Win10 laptop twice and then had a successful connection. (Hold Shift and Right Mouse click in the ADB folder on Win10 to open a different menu and the "Open Powershell Window here" option is present.)

    I now have full Unattended Remote Access to the Tab A without the annoying popup.

    Cheers! 🍺

  • LindonMorris
    LindonMorris Posts: 0 Newbie

    Many thanks smpl!

  • Zetrad
    Zetrad Posts: 0 Newbie

    This work-around worked for me. I have 2 identical Galaxy Tab A Tablets I use in trucks for ELD and this worked to access both with out the security popup!

    Thanks

Sign In or Register to comment.