teamviewer.com link icon
or
Ask The Community

Cannot connect with either WinXP or Vista systems.

Two computers WinXP and the other Vista. Both have Teamviewer vers 14.2.56676 and I've been able to do remote connections to control one from the other. Now I can't. Both tell me the other one has an old version so can't connect. I understood that both systems can work with vers 14.2. Any ideas what is wrong?

Comments

  • Fiona_G
    Fiona_G Posts: 689 Staff member 🤠

    Hi @Jpwilk,

    Thank you for your post.

    We are asking all our free users as well as the users trialing the software with older versions of TeamViewer to update to the latest version of TeamViewer, in order to continue using the software.

    Licensed users can remain using your purchased version along the lines of the product lifecycle policy. You have just to make sure that your license is activated correctly. 

    For more information regarding this topic, please refer to: Enjoy using the best version of TeamViewer we made so far! 

    Best regards,

    Fiona

    Fiona_G
  • The point is, as far as I know, I do have the latest software for both systems. Although, when I click on "Check for updates" on both systems it says there is a newer version available, vers 14.2.56677 as opposed to the vers 14.2.56676 that I have on both machines, but when I click on "Update" it says there was an error while updating on both systems. When I go to the Teamviewer site and download the "latest software" it always downloads the 14.2.56676 vers and not the 14.2.56677.

  • Hi! I install TeamViewer version 14.2.56677 on my Vista Ultimate 64-bit version manually. When upgrading to the latest version, TeamViewer returns an error code of 404. My Win10 system has version 15.12.4 installed, but it can't connect to the version running Vista. It also asks me to update to the latest version. But that's impossible! I ask for your help, your ideas! Best regards!

  • From what I understand, in order to connect to a previously free version that isn't the latest version then you have to pay for a licence for the older version in order to connect to it. So two systems with, say, free vers 14.2 that can't be updated to the latest vers can only work if you by licences for both systems.

Sign In or Register to comment.