teamviewer.com link icon
or
Ask The Community

stuck at Initializing display parameters

Rainman4500
Rainman4500 Posts: 1
edited January 11 in Linux only

I'm evaluating Team viewer for our needs.

Team viewer HOST 64 bit is installed on Ubuntu Desktop 20.10

User is configured for AUTOMATIC LOGIN after boot

HOST is configured for GRANT EASY ACCESS to my email account.

Despite the fact the user is set for AUTO LOGIN I keep getting stuck at Initializing display parameters.

When I do manage to get onsite on the Ubuntu Host I can see multiple "This session was sponsored bla bla..." which means id did try to connect multiple times. Once I close the popups I can remote login.

But the problem comes again after a power outage.

Am I doing something wrong ? Is there a different configuration I must do or Team viewer absolutely requires someone onsite to let me in? Which is useless to me.

Thanks for your help.

I'm using both the MAC and Windows client to connect to the Ubuntu machine, same problem.

Comments

  • I have the same problem .. any solution for it until now ??

  • CaptainObvious
    CaptainObvious Posts: 1 Newbie
    edited January 25

    Exact same issue. I've tried multiple versions. This problem has been going on for months, almost a year now. Ever since version 15 I've had this problem. But I can't install 14 anymore. It won't let me, and my Windows machine uses 15, anyway.

    Quick positive notes: The VT console login is neat, and works flawlessly, btw. As do the sending key combos (FINALLY! Thank you!).

    But they're a small benefit in exchange for making it nearly unusable in GUI. Overall, Teamviewer worked SO much better when it used Wine.

    The only time it works now is when I first login, on the lightdm screen. After logging in, I can use it on the GUI screen mostly without a hitch, but if I get disconnected, I have to completely log out to fix it!

    It used to, on a semi-regular basis, work again if I did a dance of VT switching, shutting off the teamviewerd service, then suspending and resuming, and finally starting up the service again, as long as I resumed on the GUI screen. But then it would stop working again if I disconnected for any reason. But now this trick doesn't work, even with older versions of 15 where it worked before.

    I haven't tried it with GDM or KDM, but it has the same problem with gnome-flashback unity, metacity, gnome desktop with gnome-shell, and everything else I've tried that I can't remember.

    It has nothing to do with whether or not any GLX/EGL/OpenGL apps are open. Compositing window-managers or non-compositing have the same issue.

    I use an NVIDIA GPU, GTX 1080 with 460.91.03 drivers. I know those aren't the newest, but the newest ones bug out on me. I'm using X, not Wayland, since Nvidia hates wayland, and there's still better compatibility with programs I use.