teamviewer.com link icon
or
Ask The Community

How Do I Install Team Viewer on a Remote Linux Server?

PostAlmostAnything
PostAlmostAnything Posts: 1 Newbie
edited March 27 in Linux only

I just downloaded TeamViewer for the first time because I noticed it on a list of solutions for remote desktop access to Linux servers. Unfortunately, your directions for how to install TeamViewer on a remote machine states "Ask your friend or family member to install the TeamViewer Full Version in their computer." (see https://community.teamviewer.com/English/kb/articles/33153-get-started-for-personal-usage#toc-hId-1614650532). How does one do that if the remote computer is a Linux server in another country?

I need to know how to install TeamViewer using SSH or cPanel on a centos 7 machine. I can't simply ask someone to do it for me since my VPS is unmanaged.

Tagged:

Answers

  • PostAlmostAnything
    PostAlmostAnything Posts: 1 Newbie

    I tried the instructions at https://community.teamviewer.com/English/kb/articles/30708-how-to-install-teamviewer-on-red-hat-and-centos but they only work for the download. The install results in a whole bunch of dependency errors like:

    Error: Package: teamviewer-host-15.16.8-0.x86_64 (/teamviewer-host.x86_64)

          Requires: libQt5WebKit.so.5()(64bit) >= 5.5

    Error: Package: teamviewer-host-15.16.8-0.x86_64 (/teamviewer-host.x86_64)

          Requires: libQt5WebKitWidgets.so.5()(64bit) >= 5.5

  • rolandg
    rolandg Posts: 62 ✭✭
    edited March 27

    hi,

    i followed the linked instructions, and could easily install TeamViewer on a centos 7 box

    CentOS 7 ( using CentOS-7-x86_64-NetInstall-2009.iso (server GUI) )

    # cd Downloads 
    # wget https://download.teamviewer.com/download/linux/signature/TeamViewer2017.asc
    # rpm --import TeamViewer.asc 
    # yum install epel-release
    # wget https://download.teamviewer.com/download/linux/teamviewer-host.x86_64.rpm
    # yum install ./teamviewer-host.x86_64.rpm 
    

    which presents the following resolved dependencies list:

    Dependencies Resolved


    ========================================================================================================

     Package                                    Arch                          Version                             Repository                                      Size

    ========================================================================================================

    Installing:

     teamviewer-host                            x86_64                        15.16.8-0                           /teamviewer-host.x86_64                         68 M

    Installing for dependencies:

     qt5-qtdeclarative                          x86_64                        5.9.7-1.el7                         base                                           3.2 M

     qt5-qtlocation                             x86_64                        5.9.7-1.el7                         base                                           923 k

     qt5-qtquickcontrols                        x86_64                        5.9.7-1.el7                         base                                           1.1 M

     qt5-qtsensors                              x86_64                        5.9.7-1.el7                         base                                           208 k

     qt5-qtwebchannel                           x86_64                        5.9.7-1.el7                         base                                            78 k

     qt5-qtwebkit                               x86_64                        5.9.1-2.el7                         epel                                            10 M

     qt5-qtx11extras                            x86_64                        5.9.7-1.el7                         base                                            27 k

     qt5-qtxmlpatterns                          x86_64                        5.9.7-1.el7                         base                                           1.0 M

  • PostAlmostAnything
    PostAlmostAnything Posts: 1 Newbie

    After it shows the dependency list how you get your machine ID and anything else necessary to login remotely?

  • PostAlmostAnything
    PostAlmostAnything Posts: 1 Newbie

    So I haveTeamViewer host installed but still no way to get the id number of the remote computer because nothing in the SSH output included anything like that. Without an ID how do I connect remotely?

    Also, I could download wget https://download.teamviewer.com/download/linux/signature/TeamViewer2017.asc
    but when I ran rpm --import TeamViewer.asc 
    

    it said error: TeamViewer.asc: import read failed(2).

  • PostAlmostAnything
    PostAlmostAnything Posts: 1 Newbie

    I logged in via teamviewer, but it is just a Linux terminal login screen. There is no desktop type user interface. Do Linux servers not have a desktop like Windows servers do?

  • PostAlmostAnything
    PostAlmostAnything Posts: 1 Newbie

    I just installed GNOME Desktop but cannot complete the setup because I don't know how to take control of the remote mouse icon via TeamViewer.

  • rolandg
    rolandg Posts: 62 ✭✭

    hi,

    running

    # teamviewer info

    reports the TeamViewer ID

    teamviewer also understands the command passwd via a cli parameter, but crashes for me.

    I reported the issue here: https://community.teamviewer.com/English/discussion/112747/linux-v15-16-8

Sign In or Register to comment.