teamviewer.com link icon
or
Ask The Community

"The entered license is invalid"

theturnlab
theturnlab Posts: 1 Newbie
edited April 19 in General Questions

Incredibly frustrated with TeamViewer's service or lack thereof. I purchased a license weeks ago, received my confirmation email as well as the email with activation link however when I login it says I'm on a free subscription. I have my receipt and confirmation to prove that I did indeed purchase a license. When clicking the "Activate" button, a TeamViewer window opens in my browser with the notification, "the entered license is invalid". I've tried calling but apparently phone support isn't included. I've tried chatting but it's just a robot providing a link to the activation help, which does nothing for me. Would love some help so we can actually use this product, otherwise we may switch providers.

Answers

  • JoshP
    JoshP Posts: 468 Senior Moderator

    Hello @theturnlab

    Thank you for your post, and welcome to the TeamViewer community!

    I can confirm that no license is currently activated to your account.

    It appears, however, that you purchased a Business License, which does include phone support as well as the ticket support.

    If you could please PM me your order number, I am happy to take a closer look at your case.

    Thanks in advance!

    Josh P.
    Senior Community Moderator

    Did my response answer your question? Help out others and select it as the Accepted Answer

Sign In or Register to comment.