teamviewer.com link icon
or
Ask The Community

What version of TeamViewer will work with XP Pro SP2?

It isn't listed on the Supported Operating Systems article https://community.teamviewer.com/English/kb/articles/24141-which-operating-systems-are-supported

XP Pro SP3 lists support up to TV 14.2, but inly 14.7 is available for download, so I can't try it.

I've currently got TV 10 installed, but that's going to be disabled soon.

I've tried the automatic update from within TV itself, and a manual installation of TV13 and TV12.

I'm reluctant to upgrade from XP SP2 to XP SP3 because there may be compatibility issues with the software I'm running.

Thanks,

Ian Shaw

Best Answer

  • JeanK
    JeanK Posts: 4,170 Moderator
    Accepted Answer

    If you download TV 14 on your Windows XP device, it will trigger automatically the 14.2 instead of the 14.7 version.

    Alternatively, you can also request the installer of 14.2 via ticket by reaching out to our customer support.

    Again, as the SP2 version is not officially supported, there is no solution we can offer you regarding these devices. Very sorry...🙏

    French Community Moderator

Answers

  • JeanK
    JeanK Posts: 4,170 Moderator

    Hello @IanShaw,

    There are no TeamViewer versions that are compatible with Windows SP2.

    French Community Moderator
  • IanShaw
    IanShaw Posts: 4 ✭✭

    Bonjour @JeanK Thanks for the swift reply. Ouch! That's awkward.

    We've a number of operational systems running XP Pro SP2. We, and our customers, would be quite nervous about stopping a working plant to perform an entire OS upgrade.

  • JeanK
    JeanK Posts: 4,170 Moderator

    @IanShaw indeed, it could be that TeamViewer is running smoothly on Windows XP SP2 devices.

    However, if there are bugs/ requests for troubleshooting, our engineers/customer support won't be able to help as it is not officially supported.

    Please see our full list of compatibilities here:

    I hope this clarifies the concern.

    French Community Moderator
  • IanShaw
    IanShaw Posts: 4 ✭✭

    I've seen that compatibility chart before, and it doesn't list XP SP2 at all. I've now tried TV 11, 12 and 13, but it won't install on SP2.

    When installing, I get error messages: "The TeamViewer service could not be started. The installation will be continued." Then, "The procedure entry point GetLogicalProcessorInformation could not be located in the dynamic link library KERNEL32.DLL."

    TV 14.2 is the latest version for XP SP3, but it is not provided on the download page. Do you know where I can get it from? I might need it for other XP computers.

    I seem to be in trouble for this particular site. I can't upgrade to SP3 because the applications software I'm using is only compatible up to SP2. I may need to find a solution other than TeamViewer. (This is very annoying since I have paid for a perpetual licence that TV will no longer honour.)

  • JeanK
    JeanK Posts: 4,170 Moderator
    Accepted Answer

    If you download TV 14 on your Windows XP device, it will trigger automatically the 14.2 instead of the 14.7 version.

    Alternatively, you can also request the installer of 14.2 via ticket by reaching out to our customer support.

    Again, as the SP2 version is not officially supported, there is no solution we can offer you regarding these devices. Very sorry...🙏

    French Community Moderator
  • IanShaw
    IanShaw Posts: 4 ✭✭

    That's very useful to know about the 14.7/14.2 solution. Thanks.

    I'll look elsewhere for a XP SP2 solution.

Sign In or Register to comment.