How to force Client use proxy in private LAN (no internet)?

mailing
mailing Posts: 9 ✭✭
edited July 2021 in General questions

Hi,

I have installed in a private network (NO internet) the following setup with latest release of free version:

Teamviewer SERVER 1 <-> LAN 1 <-> ROUTER/FIREWALL <-> LAN 2 <-> PROXY SERVER <-> LAN 3 <-> Teamviewer CLIENT 1

There is no IPv4 routing enabled between the client and server, so direct tcp/udp connections are not possible. I have enabled proxy settings both in server and client, enabled LAN connections on both server and client, however when I attempt to connect from client to server, observing logs and tcpdump traffic I see that the client ignores proxy settings and always attempts to initiate a TCP connection directly to the server.

How do I force the client to use the proxy to connect to the server? If I enable IPv4 routing between LAN3 and LAN1, the client connects. But with IPv4 routing unreachable (or Firewall policies to reject LAN3 traffic to LAN1) the client never attempts to use the proxy and insists on opening a direct TCP connection to server.

The machines are both Linux but I have reproduced this behaviour on Windows client and server as well.

Server *does* have IPv4 routing connectivity to Proxy server. I attempted to uncheck "use UDP" on client and restarting, still ignores me and goes direct instead of contacting the proxy.

Comments

  • mailing
    mailing Posts: 9 ✭✭

    $ cat .config/teamviewer/client.conf

    TeamViewer User Settings

    # It is not recommended to edit this file manually



    [int32] HideOnlineStateOfTV = 1

    [int32] LastCorrectorRun = 1

    [int32] MainWindowSize = 885 494 122 133

    [strng] MultiMedia\AudioSendingVolumeV2 = "0.70"

    [strng] MultiMedia\AudioUserSelectedCapturingEndpoint = "null"

    [strng] MultiMedia\AudioUserSelectedRenderingEndpoint = "null"

    [int32] OnboardingTaskState = 1 1 1

    [strng] Proxy_IP = "192.168.50.50:3128"

    [int32] Proxy_Type = 2

    [bin ] SUID = f49b665f06724d5787d159bb5ff6960b

    [int32] SendWindowsKeys = 1

    [int32] useUDP = 0


    $ sudo egrep -v ' PK = | SK = | SRPPasswordMachineIdentifier = ' /etc/teamviewer/global.conf

    TeamViewer Global Settings

    # It is not recommended to edit this file manually



    [int32] ClientIC = -2070770967

    [bin ] ConnectionHistory = aae7a9fea59f7598b85d09166680ae9f

    [int32] EulaAccepted = 1

    [int32] General_DirectLAN = 1

    [int32] LanOnly = 1

    [strng] LastMACUsed = "782bcb098c09" "782bcb098c0a" "782bcb098c09"

    [strng] LastSelectedLanguage = "en"

    [strng] Proxy_IP = "10.1.50.50:3128"

    [int32] Proxy_Type = 2

    [strng] Version = "15.19.3 "

    [int32] useUDP = 0

  • mailing
    mailing Posts: 9 ✭✭
    edited July 2021

    $ sudo tar -cf opt-teamviewer-logfiles.tar.bz2 install_teamviewerd.log TeamViewer15_Logfile.log TVNetwork.log

    $tar -cf home-user-dotlocal-share-teamviewer15-logfiles.tar.bz2 gui.log startup.log TeamViewer15_Logfile.log


    The uploaded file did not have an allowed extension.

    Only the following extensions are allowed.

    mp4, jpg, jpeg, gif, png, bmp, tiff, ico.


    uploaded here if forum does not allow uploading log files.

    [The link has been removed as per the community guidelines.]

  • mailing
    mailing Posts: 9 ✭✭

    [The link has been removed as per the community guidelines.]

    then please allow attaching log files!!!