teamviewer.com link icon
or
Ask The Community

Cannot connect to an account after installing Teamviewer in new Laptop

Hi All,

I have been using Teamviewer to connect to my brother's PC in Australia. 2 days ago I got a new laptop, installed old hard drive in this laptop so now I have New SSD with windows 10 installed and old hard drive with old windows 7. This laptop runs windows 10 only not windows7. Then I installed TV15 on this new drive. Old drive had TV8 installed. By mistake I ran the old version from old windows and it ran. In old TV my brother's account was added for my unattended access.

Issue is after installing new TV15, I am not able to connect to my brother's PC whenever I try to connect it says "could not connect, Reason unknown". I am able to connect to someone other's account and if someone else tries connecting to him that too is not an issue. Only when I try to connect to him it turns down the request.

I tried uninstalling the TV and then removed all the files in the C drive and also removed all the entries in the Regedit (as many I could identify, using search feature). Again installed and still same result. I even tried installing version 12 but of no use.

Someone please help me identify the issue and solution for the same. Thanks in advance.

Answers

  • JoshP
    JoshP Posts: 844 Senior Moderator

    Hello @Saurabh82

    Thank you for your post, and welcome to the TeamViewer community!

    As you mentioned both TeamViewer 8 and 12, please ensure that the latest version (15.22.3 at the time of this writing) is on both devices, and try again. Please know that connections to any older version requires a license.

    (Here's a little backstory:) In 2018 we asked all users of the free version of TeamViewer to update to the latest version. While TeamViewer is always backwards compatible, this change made it so that a licensed commercial account is needed in order to make a connection to said older version.

    If you do have a license, please ensure you are logged in correctly.

    Without a TeamViewer license, attempting connections to an older version sometimes results in some rather... nondescript (😅) errors such as the one you've encountered. Alternatively, you may also see a slightly more informative message stating the remote device is "running an outdated version" and a prompt to please update it before trying again.

    In any case, should the issue persist, please remove and re-add your brother to your Computers & Contacts list; as connections are possible from other devices/accounts, we can safely assume the issue does not reside on their device!

    Should the issue persist, feel free to reach back out to us here. Thanks in advance!

    Josh P.
    Senior Community Moderator

    ---

    Did my response answer your question? Help out others and select it as the Accepted Answer