teamviewer.com link icon
or
Ask The Community

cursor position is incorrect when using latest new version

mlrobins
mlrobins Posts: 5 ✭✭
edited January 17 in General Questions

With the update to Version: 15.25.5 (5ceca702ecc for mac), I am now unable to control the cursor position from either of my IOS devices. Careful examination shows that the cursor position shown on the IOS devices does not match the cursor position on my mac. If I enable "show cursor" I will see two cursors on the screen that are off by about 4 inches on the screen) I am using a three monitor system, and up till now have had no problem with operation and previous versions.


Running Teamviewer 15.25.1716CL on my iphone and ipad.

Best Answer

  • JeanK
    JeanK Posts: 5,594 Community Manager 🌍
    edited January 25 Answer ✓

    Hello all,

    We just released version 15.26.4.

    Could you please update your clients and test if this release fixed the issue?

    Many thanks in advance to all of your for your support. 🙏

    Community Manager

    ---

    Did my response answer your question? Help out others and select it as the Accepted Answer

«13

Answers

  • bcmccauley
    bcmccauley Posts: 3 ✭✭

    My iPad just upgraded and the Teamviewer settings have gotten worse. Specifically, in order to get the keyboard attached to my iPad to work, I have to tap the keyboard key and reduce it so the one on screen doesn't show. It's about 5 extra steps just to be able to type when I'm logged into Teamviewer.

    Additionally, they got rid of the ability to quickly adjust display settings. My desktop has a 34" widescreen which doesn't fit well on the iPad screen so I previously would quickly adjust it to a more legible display setting. Is anybody else having this problem?

  • MihaKusa
    MihaKusa Posts: 4 Newbie

    Same for me. I have a smart keyboard, I just don't find how to use it. I only can use the touch keyboard.

  • bcmccauley
    bcmccauley Posts: 3 ✭✭

    Did it just start happening for you as well, MihaKusa?

  • MihaKusa
    MihaKusa Posts: 4 Newbie

    yeah it just started yesterday. I use the app for more than 1 year without any problem. Since the last update, it doesn't work. I have a new menu in the bottom right with options, but nothing about touch keyboard to activate or disable...

  • Same problem. Can’t use my iPad attached keyboard, only the on-screen keyboard. Pointless.

  • sergrahi
    sergrahi Posts: 1 Newbie

    Same here. There is a 'disable remote input' option but it's Off and I have played with it to check if works but no luck. I use a Logitech combo touch attached to my iPad Pro and the mouse works but not the keyboard input.

    I am trying to control a windows PC which is in my list of computers, no problem navigating or accessing the computer, it's just the remote input that does not work. Last app versions up to November 14 2021.

  • bcmccauley
    bcmccauley Posts: 3 ✭✭

    I got a message from Teamviewer after sending in a complaint and they said they are working on a fix since it seems like all iPad users are having an issue. Hopefully they solve the problem quickly.

  • Proxus
    Proxus Posts: 1

    Just wanted to add my name to the pile of users encountering this issue. I have been remoting from my iPad for over two years now with little to no issue. Now not only do I have to activate the keyboard mode to type (and can no longer easily switch screens) but it seems that half the time the arrow keys are unresponsive and the delete (backspace) never works leaving me stuck selecting via shift + arrows or using my apple pen to select things to type over…

    Please, please, please fix this fast!

  • Rolly888
    Rolly888 Posts: 2 Newbie

    same problem

  • AnnickPerrault
    AnnickPerrault Posts: 2 ✭✭
    edited December 2021

    i'm running TeamViewer 15.25.5 on my 2 mac Catalina. When I connect remote, since yesterday, the cursor is offset of about 5 inch left in the window. Any idea

  • mlrobins
    mlrobins Posts: 5 ✭✭
    edited December 2021


    I've attached a photo with "show cursor" enabled so that you can see how far off the cursor is from the actual position.

  • knuky
    knuky Posts: 1

    Have the same issue. Remoting from Windows device to iMac after upgrade to MacOS Monteray. Cursor position on remote screen is incorrect and unusable. Was fine on previous version of MacOS.

  • Mr_KOP
    Mr_KOP Posts: 1


    Hello, I had same issue. Remote from mac Monteray (M1 chip) to Big Sur (Intel). Both are newest teamviewer version. I didn't see this issue before update



  • agents006
    agents006 Posts: 2 Newbie

    I have this same issue directly after updating to 15.25.5 on Mac. This is unusable.

  • agents006
    agents006 Posts: 2 Newbie

    I have this same issue — updated to Mac 15.25.5 today. "Show your partner's cursor" is also unchecked with no effect.

    Unusable.

  • JeanK
    JeanK Posts: 5,594 Community Manager 🌍
    edited December 2021

    Hello @mlrobins @knuky @Mr_KOP and @agents006,

    Thank you for sharing your feedback.

    I wanted to inform you all that our dev team is currently working on a solution.

    In the meantime, we can offer you two workarounds:

    • If you need to keep using mulptile displays, make sure the primary display (the one that has the Dock) is arranged as the left-most display in System Preferences > Displays. If more than 2 displays are being used, the order of the 2nd, 3rd, etc. displays may also need to be changed if the mouse position is wrong there.
    • Only have one display connected to the remote Mac.

    I will keep you updated here as soon as we know more about this issue.

    All the best ❄🎄🎅

    JeanK

    Community Manager

    ---

    Did my response answer your question? Help out others and select it as the Accepted Answer

  • jeffcrigler
    jeffcrigler Posts: 2 ✭✭

    I have a Mac Mini with dual monitors I am removing into from an iMac. All was working fine. I could remote in using password and login, control keyboard and mouse, do everything.

    Something is now preventing me from using the mouse. I can use the keyboard as input, for example to log in, or ope into a text box if the cursor is positioned there.I have uninstalled and re-installed multiple times. I have checked the accessibility settings in Mac OS, Team Viewer itself in Help -> Check system Access shows all permissions allowed.


    Any Ideas?

  • Lisa_2021
    Lisa_2021 Posts: 1 Newbie

    Hi jeffcrigler

    I have the same issue. All Access granted, but mouse is still not working on via TeamViewer. I have Mac OS swell.

    Hope someone has a good idea to fix it. :-)

  • Greatchap
    Greatchap Posts: 1

    Hello Everyone,

    I am using commercial version of team viewer. When I use teamviewer to connect from my IPAD PRO to Windows 10 PC then the shift, arrow and misc keys in the bluetooth keyboard stop working.

    Only the number and alphabet keys work. I do not remember this issue earlier. My teamviewer is 15.x in windows pc and latest app in ipad. Other wise in other apps in ipad the keyboard works fine. In RDC also keys such as arrow keys work okay.

    Please advice what to do.

    Regards,

    GR

  • Crisabexus
    Crisabexus Posts: 2 ✭✭

    I got the same issue.

  • RAC1
    RAC1 Posts: 1

    Remote to M1 mac mini with two monitors is impossible. The problem is that the cursor by remote is on the wrong monitor. Work around #1 above leads to more problems. Work around #2 can't be done remotely. Hope solution or rollback to earlier version is coming. Thank you.

  • RossB
    RossB Posts: 7 ✭✭
    edited December 2021

    I have 2 MacBook Airs I use for Ham Radio. Recently neither touch nor mouse control is working on one MacBook Air and not the other. I have no idea as to why.

    Please help!

  • Archigos
    Archigos Posts: 30 ✭✭

    I have an iMac with a secondary monitor. Everything worked fine, but I had to recently replace the hard drive in the iMac and ever since, when I connect and I'm looking at the main monitor, the mouse is stuck on the right of the screen and no clicks, etc. work. If I switch to the secondary monitor and move the mouse around, it's moving on the main screen, but if I'm not physically next to the computer, this makes it unusable since I don't know what I'm clicking/dragging.


    Any help would be greatly appreciated.

  • RossB
    RossB Posts: 7 ✭✭

    I have tried multiple macs, iPad and iPhone to try to control that MacBook air. I have compared and assured all preferences are the same in each MacBook Air. On the MacBook Air which cannot be controlled, the mouse pointer is active but nothing can be clicked except to disconnect. I am a total loss. Is there a hardware failure?

    Please help!

  • Selvatica
    Selvatica Posts: 2 ✭✭

    Same problem! Any idea to resolve it?

    Thanks!

  • RossB
    RossB Posts: 7 ✭✭

    I have 2 MacBook Airs I control remotely for Ham Radio. The mouse on one is not moving properly. This is a new problem that started suddenly. All settings are the same on both.

    The cursor moves but is not synchronized so that I can click where I want.

    Using 15.25.5 on all laptops. I have deleted and reinstalled Teamviewer on failed device.

    Suggestions please!

  • Reski
    Reski Posts: 2 ✭✭

    Same here. It used to works, but suddenly it dont.

    Previously problem with Magic Folio (cant be detected), then this…

  • Reski
    Reski Posts: 2 ✭✭

    Same problem here

  • eliejdaher
    eliejdaher Posts: 1 Newbie

    Temporary solution: Vertical Align Top for both displays.

    Best,


  • RossB
    RossB Posts: 7 ✭✭

    Therefore, I cannot click and control the remote MacBook Air. I have another MacBook Air which functions perfectly and has the same preference settings.

    Please help!