teamviewer.com link icon
or
Ask The Community

cursor position is incorrect when using latest new version

2

Answers

  • RossB
    RossB Posts: 7 ✭✭

    I have 2 MacBook Airs I control remotely for Ham Radio. The mouse on one is not moving properly. This is a new problem that started suddenly. All settings are the same on both. The cursor moves but is not synchronized so that I can click where I want. It hides at the bottom of the screen.

    Using 15.25.5 on all laptops. I have deleted and reinstalled Teamviewer but nothing has changed.

    Please help!

  • AnnickPerrault
    AnnickPerrault Posts: 2 ✭✭

    you have to change the arrangement monitor to put the second one at the RIGHT. and the mouse works come back on the first screen... but very anoying because on my both computer second screen are at the left ;-/


  • Meps
    Meps Posts: 4 ✭✭

    When I connect to my main computer from my laptop, I can use the keyboard to type on the main computer but I'm unable to click on anything with the cursor. Am I missing something? It used to work.

  • Akiho
    Akiho Posts: 634 Moderator

    Hi @Meps ,

    Thank you for your post and hope you have a wonderful holiday time😊

    Regarding the case, the remote mouse would be prioritized, and this might be the cause of the issue.

    Could you try a remote session and check the box of the "Disable remote input" option on the remote session toolbar, please?


    Hope this would be helpful🍀

    It would be really great if you could tell me this could solve your case!

    Best regards,

    Akiho


    Japanese Community Moderator / コミュニティモデレーター

  • dterrot
    dterrot Posts: 5 ✭✭
    edited January 4

    I have the same issue. Seems to happen with **Third party product** as well. [removed per Community Guidelines] and that seems to work fine although cannot change the screen resolution to resize for iPad so not a permanent fix for me

  • Meps
    Meps Posts: 4 ✭✭

    Hi Akiho

    Thanks for your response. When I select that option it tells me I have to upgrade. All I use team viewer for is to be able to control my computer thats upstairs from downstairs. I've been able to do this successfully before. Like I mentioned I can type on the keyboard and it is recognized on the upstairs computer. If I try moving the mouse, the cursor jumps to the very far right on the upstairs computer and can only be moved vertically right at the very edge of the screen. I can't move it to the left at all. It feels like a bug.

  • Meps
    Meps Posts: 4 ✭✭

    Another observation. My upstairs computer has 2 screens (I'm on a Mac if that makes a difference). When I select the main screen (right), the cursor locks to the right of the screen. When I select the second monitor (left), the cursor moves as it should but on the main (right) screen, not the one I am viewing.

  • LakewoodGuy
    LakewoodGuy Posts: 2 ✭✭

    I too am having this issue, and it is also recent.

    I have tried this with both the "Disable Remote input" checked and unchecked. Although when I check it it automatically goes back to being unchecked when I look at it after I try the test...

    When I do a full access remote into my work computer, I can see my cursor in the middle of the page. The TeamViewer cursor that I am controlling via my iPhone goes to the top of the page as I try to click on the top banner of the screen (to turn off the computer, think hitting the apple on a Mac). The cursor from my computer does not move, it does not go up there.

    From further testing it seems as though there is a distance between the two cursors which is why it doesn't do what I want. I am moving the TeamViewer cursor on my iPhone and I can see that the cursor on my computer is moving in the same manner but a few inches below. As such, I can't even get that cursor to go to the top of the page as it stops moving up at about half the screen up and doesn't go any further.

    So it is able to click, but it is not in line with my TeamViewer Cursor. How do I get them to line up so I can click on the top of my pages?

  • Archigos
    Archigos Posts: 30 ✭✭

    There have been other threads that have stated downgrading to 15.24.x will fix this issue while we wait for a new version... However, downgrading doesn't seem to be as simple as it should be... is there any way someone can post a link to the 15.24.x version for us to use in the meantime?

  • Akiho
    Akiho Posts: 634 Moderator

    Hi @Meps and @LakewoodGuy,

    Thank you for your response and detailed information✨✨

    From the given information, I could confirm that your case is related to this thread: cursor position is incorrect when using latest new version.

    Since @JeanK has introduced 2 workaround methods on the thread, I'll quote them to you right away😉

    In the meantime, we can offer you two workarounds:

    1) If you need to keep using multiple displays, make sure the primary display (the one that has the Dock) is arranged as the left-most display in System Preferences > Displays. If more than 2 displays are being used, the order of the 2nd, 3rd, etc. displays may also need to be changed if the mouse position is wrong there.


    2) Only have one display connected to the remote Mac.


    You may find useful information from the thread, please feel free to check it out !

    I wish you a great end of the year🍀✨

    Best regards,

    Akiho


    P.S. The issue has already been reported and our development team is currently working on this case.


    Japanese Community Moderator / コミュニティモデレーター

  • Meps
    Meps Posts: 4 ✭✭

    Thanks for the update. Hopefully theres a fix soon. My work often relies on 2 screens :)

  • Nancy_M_1957
    Nancy_M_1957 Posts: 1 Newbie

    I connect to my remote computer with no problem. But once connected the cursor does not work. It moves up and down on the far-right side of the screen. I am connecting to an MacOS from my HP Windows.

  • Archigos
    Archigos Posts: 30 ✭✭

    This is a known issue with 15.25.x and is being looked into. If you have the installer for 15.24.x you can install that to fix the problem until a new version is released.

    Otherwise, if you have multiple monitors on the Mac, you can try one of the workarounds (neither worked for me) and they are: 1) Make sure the main monitor is the farthest left in the display order and the dock is on the left-hand monitor or 2) If the main monitor is on the right, you can try to align the top of each monitor in System Preferences.

  • alec2219
    alec2219 Posts: 3 Newbie

    I can see the mouse moving on the far right hand corner of the screen, But its not going where it is pointed on the remote computer. I have uninstalled and reinstalled, with the same issues.

  • John_snith55
    John_snith55 Posts: 2 Newbie

    Did you try turning it off and then back on?

  • alec2219
    alec2219 Posts: 3 Newbie

    ... yes....

  • John_snith55
    John_snith55 Posts: 2 Newbie

    Did it work…?

  • alec2219
    alec2219 Posts: 3 Newbie
    edited January 3


  • Archigos
    Archigos Posts: 30 ✭✭

    This is a known issue with 15.25.x.... I can confirm a current workaround is installing 15.24.x overtop the current install and NOT updating again until a new version is released.

  • ferdware
    ferdware Posts: 1 Newbie

    For me I had to downgrade to version 15.24.5 ( Mac ). fixed the issue until TV fixes lates version. No way I'm gonna re-arrange my monitors.

  • DesignCorp
    DesignCorp Posts: 5 ✭✭

    Reporting the same issue with client version 15.25.x (and I think it's only with M1 Macs) with multiple external displays. Users report seeing my remote mouse stuck in the lower right corner of the screen. If the user disconnects the external monitors I can control properly.

  • Archigos
    Archigos Posts: 30 ✭✭

    It's not just M1's... my 2017 iMac had the same issue on 15.25.x

  • Ha1212
    Ha1212 Posts: 1

    I'm having the same issue. Even if I put the primary display on the left most in the display arrangement, the cursor position is still off. I had to select mirror all my displays to have the cursor back to its correct position.

    I'm running on Mac OS 10.15.7 and Teamvciewer 15.25.5.

  • Pdxpaul
    Pdxpaul Posts: 6 ✭✭

    Not sure if related but on latest version on iPad I am finding that the mouse pointer is frustratingly a little off, I have to position is a tiny bit to the right of what I am tying to click.. making it very difficult to use!

  • masterbeat
    masterbeat Posts: 4 ✭✭

    Hello, now facing same issue, making TeamViewer unusable. I remote in from a new MacBook 16 M1Max running Monterrey to a Mac Pro running Big Sur. The Big Sur Mac Pro has 3 monitors.

    Now, when connecting, I can have the computers side by side, and it's obvious Team Viewer can't tell which monitor is which. On the TeamViewer remote it shows I'm working on one monitor (cursor moving on monitor 2), but watching the actual computer, cursor is moving on monitor 1, and so on.

    Changing active displays doesn't work.

    I've had this same setup for 2 years now (always connecting from a mobile laptop to the home computer that has always had 3 displays), with no issues... but now can't control - not sure if it's the upgrade to Big Sur on the Mac Pro or if it's the new laptop running Monterrey that is causing the issue.

  • mforte
    mforte Posts: 1 Newbie

    Hi!

    Can confirm we are also having the same issue when the user has dual desktops on MacOS

  • Luke_H
    Luke_H Posts: 3 ✭✭

    Same issue... remote control has become a dangerous game with this new version... accidental clicks and mouse button getting stuck causing unwanted drag n drops can be disasterous

  • Jonas_7
    Jonas_7 Posts: 2 ✭✭

    it happened to me after the latest release 15.25.1. Same problem occurred after the 15.24 version had been released, too but it was fixed immediately with a new update.

    We are still waiting Teamviewer to release new update to fix the keyboard problem just like it did last month.

    I wish it was possible to install previous versions of Teamviewer on iPad.

  • Roscoepc
    Roscoepc Posts: 1

    I’m also having these problems - connecting between an iMac and a Mac Mini. Both have same (latest) version of TeamViewer. Mac Mini has latest version of Mac OS. iMac has earlier version of Mac OS.

    I can remotely connect from iMac to Mac Mini and fully control the Mac Mini. But the problem occurs when remotely connecting from Mac Mini to iMac.


    TeamViewer guys - can you give us an approximate date this will be fixed? This problem means I can now no longer work from home (on Mac Mini) because I cannot control my work computer

  • DonaemouS
    DonaemouS Posts: 1
    edited January 13

    I dunno if this thread is good as well, but I have the same issue with Windows version 15.25.8 when connecting to a Mac with dual or multi-display. The cursor is shown in the wrong display. Es, I see in my session I'm using dx display (or menu bar display), but my clicks are on the second display.

    EDIT: The Mac is using the TeamViewer Host version 15.25.5. Later today I will post a picture.